#20779 [Opn->Dup]: Several dll entry points not found in php4ts.dll
| From: | charlie at rahinston dot com | Date: | Tue, 03 Dec 2002 05:56:11 +0000 |
| Subject: | #20779 [Opn->Dup]: Several dll entry points not found in php4ts.dll | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-26458@lists.php.net to get a copy of this message | ||
ID: 20779
User updated by: charlie@rahinston.com
Reported By: charlie@rahinston.com
-Status: Open
+Status: Duplicate
-Bug Type: *Configuration Issues
+Bug Type: Apache related
Operating System: Win2k Pro
PHP Version: 4.3.0RC2
New Comment:
Hi there
Additional Category: Apache
Just to clarify some points, i am using Apache 2.0.43 not Apache
2.0.39. So does the warning (below), of which I was aware of apply to
newer versions of Apache (ie 2.0.40 and later). If its a known issue,
then what measure have been taken to fix it. I believe its a PHP
error. Apache runs everything else okay. The apache server environment
is only for local development (i.e desktop).
Secondly, I am using 4.2.3, which I downloaded on Saturday, Australian
DST.
Charlie
PS The documentated warning about PHP and apache on windows for sapi
seem to contradictory .... comapre these two sentences:
"PHP 4.2.3 its known to work in conjunction with Apache 2.0.39." --- so
PHP 4.2.3 works.
"We do not recommend to use PHP 4.2.3 along with Apache 2.0.39." --- so
as it works, it is not recommened. Eh?
"Don't try to use this version of PHP with any other version of
Apache." --- Is that earlier (older) or later (newer) versions of
apache i.e before/after v.2.0.39.
A fuller explaination would be preferable.
I know that a the PHP 4.2.2 sapi worked with Apache 2.0.39, via console
set up (not as a service) - although it was fiddley and a manual start
up - but no errors.
Previous Comments:
------------------------------------------------------------------------
[2002-12-02 23:55:34] charlie@rahinston.com
Hi there
Additional Category: Apache
Just to clarify some points, i am using Apache 2.0.43 not Apache
2.0.39. So does the warning (below), of which I was aware of apply to
newer versions of Apache (ie 2.0.40 and later). If its a known issue,
then what measure have been taken to fix it. I believe its a PHP
error. Apache runs everything else okay. The apache server environment
is only for local development (i.e desktop).
Secondly, I am using 4.2.3, which I downloaded on Saturday, Australian
DST.
Charlie
PS The documentated warning about PHP and apache on windows for sapi
seem to contradictory .... comapre these two sentences:
"PHP 4.2.3 its known to work in conjunction with Apache 2.0.39." --- so
PHP 4.2.3 works.
"We do not recommend to use PHP 4.2.3 along with Apache 2.0.39." --- so
as it works, it is not recommened. Eh?
"Don't try to use this version of PHP with any other version of
Apache." --- Is that earlier (older) or later (newer) versions of
apache i.e before/after v.2.0.39.
A fuller explaination would be preferable.
I know that a the PHP 4.2.2 sapi worked with Apache 2.0.39, via console
set up (not as a service) - although it was fiddley and a manual start
up - but no errors.
------------------------------------------------------------------------
[2002-12-02 21:41:43] philip@php.net
From the docs:
----
http://www.php.net/manual/en/printwn/install.apache2.php
----
Note: Apache 2.0 SAPI-support started with PHP 4.2.0. PHP 4.2.3 its
known to work in conjunction with Apache 2.0.39. Don't try to use this
version of PHP with any other version of Apache. We do not recommend to
use PHP 4.2.3 along with Apache 2.0.39.
----
And btw, are you trying 4.2.3 or 4.3.0RC2, you list both in this bug
report. This looks like an Apache2 related bug so the category may
want to reflect that but I personally have no idea so won't touch it :)
------------------------------------------------------------------------
[2002-12-02 21:28:38] charlie@rahinston.com
Please excuse the spelling mistake : dynamic link librart should be
dynamic link library.
------------------------------------------------------------------------
[2002-12-02 21:26:21] charlie@rahinston.com
I have installed Apache 2.0.43 as a service on Win 2k with PHP 4.2.3.
These are upgrades from Apache 2.0.39 and PHP 4.2.2. Now I had
previuosly enabled the following php extensions and they worked fine in
the older setup. Now, after the upgrade, they don't.
They are bz2, ctypye, curl, ming, pdf, zlib.
------------------------------------------------------------
The errors are:
php_bz2.dll
Apache.exe - Entry Point Not Found
The procedure entry point php_file_le_fpoen could not be loacted in the
dynamice link librart php4ts.dll
Unkown(): Unable to load dynamic library './php_bz.dll' - The procedure
could not be found'
php_ctype functions:
Warning
Function registration failed - duplicate name - ctype_alnum
Warning
Function registration failed - duplicate name - ctype_alpha
Warning
Function registration failed - duplicate name - ctype_cntrl
Warning
Function registration failed - duplicate name - ctype_digit
Warning
FunctioWarning
Function registration failed - duplicate name - ctype_print
Warning
Function registration failed - duplicate name - ctype_space
Warning
Function registration failed - duplicate name - ctype_upper
Warning
Function registration failed - duplicate name - ctype_xdigit
Warning
ctype: unable to register function, unable to load
php_curl.dll:
Apache.exe - Entry Point Not Found
The procedure entry point php_file_le_fpoen could not be loacted in the
dynamice link librart php4ts.dll
Unkown(): Unable to load dynamic library './php_bz.dll' - The procedure
could not be found'
php_ming.dll
Apache.exe - Entry Point Not Found
The procedure entry point php_fsock_fread could not be loacted in the
dynamice link librart php4ts.dll
Unkown(): Unable to load dynamic library './php_ming.dll' - The
procedure could not be found'
php_pdf.dll
Apache.exe - Entry Point Not Found
The procedure entry point zif_warn_not_available could not be loacted
in the dynamice link librart php4ts.dll
Unkown(): Unable to load dynamic library './php_pdf.dll' - The
procedure could not be found'
php_zlib.dll
Apache.exe - Entry Point Not Found
The procedure entry point php_fopen_wrapper could not be loacted in the
dynamice link librart php4ts.dll
Unkown(): Unable to load dynamic library './php_zlib.dll' - The
procedure could not be found'
End of errors details.
-----------------------------------------------------------
The workaround works by disabling these extension in the php.ini file
but this is not pratical for me long term.
The extension folder is located under :c:/php/extensions.
This problems occured after the upgrade to the latest versions of php
and apache.
Please assist, as it would be much appreciated.
Charlie
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=20779&edit=1