ID: 10969
Comment by: au_viol2002@yahoo.com
Reported By: ipcholkin@yahoo.com
Status: Bogus
Bug Type: Apache related
Operating System: Win 98
PHP Version: 4.0.5
New Comment:
Hi
I have this problem too with apache 1.3.27, php 4.2.3 (win98)
apache works alone but not apache+php
"missing dll to make php4apache.dll working" it says
and so php4apache.dll don't get loaded.
when trying to open php.exe I had the following message:
"missing odbc32.dll"
I only have odbcjt32.dll on my computer, I'll to look for odbc32.dll,
not found yet on internet.
Previous Comments:
------------------------------------------------------------------------
[2001-05-23 16:29:25] ipcholkin@yahoo.com
I found what the error was:
Apache could not find odbc32.dll.
After I installed this library the server started normally.
------------------------------------------------------------------------
[2001-05-21 09:36:13] ipcholkin@yahoo.com
I don't see any sintax error there.
Please send detailed info.
I think scripting engine classifies this as a sintax error but indeed
there are another kind of a problem. By the way, the full message
I see in my console window is:
"Syntax error on line 979 of k:/apache/apache/conf/httpd.conf:
Cannot load k:/apache/apache/modules/mod_php4/sapi/php4apache.dll into
server: (1157)
Cannot load dinamic library:"
The last sentence was written in russian, in accordance with
OS-specific regional settings and then translated by me in English.
That's why I omitted this message in the first edition of this bug
report.
------------------------------------------------------------------------
[2001-05-19 10:50:01] jmoore@php.net
Bogus
------------------------------------------------------------------------
[2001-05-19 10:44:27] jmoore@php.net
This is not a bug in PHP. You have made a mistake in your httpd.conf on
line 979. fix this syntax error and try again.
------------------------------------------------------------------------
[2001-05-19 10:14:54] ipcholkin@yahoo.com
When I try to start apache, it says:
"Syntax error on line 979 of k:/apache/apache/conf/httpd.conf:
Cannot load k:/apache/apache/modules/mod_php4/sapi/php4apache.dll into
server: (
1157)"
Added lines in apache.conf are:
-------CUT HERE------------
# for the apache module
LoadModule php4_module modules/mod_php4/sapi/php4apache.dll
AddType application/x-httpd-php .php4
#for the cgi binary (you can use that one compiled with force cgi
redirect too)
ScriptAlias /php4/ "k:/apache/apache/modules/mod_php4/"
Action application/x-httpd-php4 "/php4/php.exe"
AddType application/x-httpd-php4 .php
-------CUT HERE------------
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=10969&edit=1