#10571 [Com]: blank browser with Xitami

From: Date: Sun, 08 Dec 2002 14:11:41 +0000
Subject: #10571 [Com]: blank browser with Xitami
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-27036@lists.php.net to get a copy of this message
ID: 10571 Comment by: jeanmarcvdlinden@chello.nl Reported By: nigglefish@hotmail.com Status: Closed Bug Type: Other web server Operating System: win2000 PHP Version: 4.0.4pl1 New Comment: My problem is solved. I know this subject is closed, but thought would be worth mentioning since others, newbies like me might run into the same problem. I downloaded and installed latest snapshot of PHP (v4.4.0dev), and used php-cgi.exe for Xitami, and now php documents also work in other folders than xitami\webpages (I didn't test php.exe, only php-cgi.exe) It works fine now :o) Previous Comments: ------------------------------------------------------------------------ [2002-12-04 11:36:35] jeanmarcvdlinden@chello.nl I followed Tito's advice and finally I got PHP running with Xitami, but not in the way I want it to: PHP files can only be run whith XITAMI\WEBPAGES\ as document root directory!!!! (setting doc_root doesn't work!!!!) My Xitami is installed on D:\Xitami, my webfiles are on D:\web-filez. Now I have to move all PHP content from D:\web-filez to D:\xitami\webpages in order to make them work :o( so I guess this is still a BUG and will be fixed in the future. Chau, JM. ------------------------------------------------------------------------ [2002-10-01 13:32:52] costati@tin.it I had the same problem. This is how I solved. If your PHP has been compiled with FORCE_CGI_DIRECT, you have to leave blank doc_root in php.ini and uncomment the line: cgi.force_redirect=1 In php.ini set cgi.redirect_status_env to an environment variable name, eg PHPON. cgi.redirect_status_env=PHPON; In autoexec.bat set the environment var to any value. eg add the line: set PHPON yes Also in autoexec.bat remember to add your PHP installation (eg c:\php) to the path. tito ------------------------------------------------------------------------ [2001-07-23 18:38:05] andy@php.net no feedback after 30 days. ------------------------------------------------------------------------ [2001-06-23 14:55:41] sniper@php.net Does this happen with PHP 4.0.6 ? ------------------------------------------------------------------------ [2001-05-01 01:04:17] nigglefish@hotmail.com I am running a Xitami (v2.4c1) server on win2000. I used the install shield to install PHP 4.0.4. All the filters and stuff seem to be set up right in Xitami. I have installed and used PHP 3 with the same server and followed the same steps to configure it for PHP 4. I have set the "doc_root" in the php.ini file to "C:\Nigel\VWS". However, when I run a script nothing happens: I get a blank browser screen. Setting the "display_startup_errors" in the php.ini file I get the message: "Fatal error: Unable to open C:\Nigel\VWS\ in Unknown on line 0" I tried commenting out the "doc_root" setting in the php.ini file and I get the same error only it's pointing to the cgi-bin directory of Xitami (even though I have told it to use "c:\Nigel\VSM\" for files). I tried pointing the "doc_root" to the complete path of the php script file including it's filename and that worked and processed the file normally... every time the server started up php for any page. I really am stumped. Thanks in advance. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/10571 -- Edit this bug report at http://bugs.php.net/?id=10571&edit=1

« previous php.bugs (#27036) next »