#15333 [Opn->Fbk]: strndup access violation
| From: | iliaa@php.net | Date: | Sun, 08 Dec 2002 23:32:42 +0000 |
| Subject: | #15333 [Opn->Fbk]: strndup access violation | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-27096@lists.php.net to get a copy of this message | ||
ID: 15333
Updated by: iliaa@php.net
Reported By: david@harksystems.com
-Status: Open
+Status: Feedback
Bug Type: IIS related
Operating System: Windows 2000 Pro
PHP Version: 4.3.0-dev
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php4-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-latest.zip
There was patch commited to the CVS on 2002/12/02 that may have solved
the problem.
Previous Comments:
------------------------------------------------------------------------
[2002-12-01 16:19:51] shane.hyde@apcairsea.com.au
I can easily reproduce this. With a simple <? phpinfo(); ?> 5
refreshes kills PHP and inetinfo. I have narrowed it down to a
auto_prepend_file setting in php.ini. With that setting disabled then
I cannot crash it. Hope this helps.
------------------------------------------------------------------------
[2002-11-27 14:37:58] kees@boekel-it.nl
We had the same "php4ts!zend_strndup + 0x2B + 0xA05CB1AD." error on our
win2k server iis5 and php4.2.1.
Stan.nospam, and maybe others as well mentioned about setting isapi
filters.
We added an isapi filter pointing to the same php4isapi.dll as in the
apps mappings. The application which was hanging every 5 minutes
before, didn't hang since (which is for 4 days now)
------------------------------------------------------------------------
[2002-11-27 09:16:04] nytral@spamcop.net
Same issue, and even worse:
since the last MS updates (IIS, SQL, MDAC), I get a bunch
of access violations that I almost never got before.
And running manually php.cgi causes the script to quit at
the first SQL request, without warning/errors. It says
'missing cgi headers' when running under php-cgi.
I tried 4.3.0RC1, 4.3.0-dev, 4.4.0-dev (yesterday's
snapshots), all the same result.
Any PHP developper using a dual cpu Win2K platform could
test/fix this?
------------------------------------------------------------------------
[2002-11-20 14:30:05] ryanphp@ryanjameson.com
Add me to the list of people experiencing this. After a little while of
switching back and forth from AV to
working it goes to not responding at all. :-(
------------------------------------------------------------------------
[2002-11-18 18:10:24] ruslan@snip.com.ua
Hi..
i have been working on this a couple of days for now, and here are some
facts i noticed after a couple of work-arounds...
- the error occurs only on systems with Win2K (SP >= 2)
- the error WILL NOT occur if logged in as system administrator, and
the IIS security is turned to LOW !!
- the error will occur on EACH request if you fronpage extensions
installed, and a global.asa file exists on the root .
- please keep us informed of a solution
thanks...
http://www.snip.com.ua
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/15333
--
Edit this bug report at http://bugs.php.net/?id=15333&edit=1