#20942 [Opn->Bgs]: Activating extension : imap, stops Apache
| From: | derick@php.net | Date: | Wed, 11 Dec 2002 17:58:50 +0000 |
| Subject: | #20942 [Opn->Bgs]: Activating extension : imap, stops Apache | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-27389@lists.php.net to get a copy of this message | ||
ID: 20942
Updated by: derick@php.net
Reported By: dmiller@atnetplus.com
-Status: Open
+Status: Bogus
Bug Type: Apache related
Operating System: OpenBSD 3.2
PHP Version: 4.2.3
New Comment:
Sounds like a missing library on your system, you need to install
c-client (part of Washington IMAP server).
Not a bug in PHP -> bogus
Previous Comments:
------------------------------------------------------------------------
[2002-12-11 11:48:34] dmiller@atnetplus.com
This is a fresh install of OpenBSD 3.2 on an i386 type machine. qmail
for SMTP and courier for IMAP and POP3 were added and tested. The mysql
server package (from the CD)was also added. The goal is to use
squirrelmail. I downloaded the following packages from the Openbsd site
for OpenBSD 3.2:
php4-core-4.2.3.tgz
php4-mysql-4.2.3.tgz
php4-imap-4.2.3.tgz
php4-pear-4.2.3.tgz
I followed the instructions at:
http://php3.de/manual/en/install.openbsd.php
I edited my httpd.conf to show:
DirectoryIndex index.php index.html
and
AddType application/x-httpd-php .php
Apache will not start unless I disable the imap extension.
My Apache error log shows:
usr/libexec/ld.so: httpd: libc-client.so.4.0: Invalid argument
help???
------------------------------------------------------------------------
[2002-12-11 10:56:41] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php
If you can provide more information, feel free to add it
to this bug and change the status back to "Open".
Thank you for your interest in PHP.
------------------------------------------------------------------------
[2002-12-11 10:53:10] dmiller@atnetplus.com
Apache works with PHP until I do:
pkg_add php4-imap-4.2.3.tg
/usr/local/sbin/phpxs -a imap
Then:
apachectl start
/usr/sbin/apachectl start: httpd could not be started
My /var/www/logs/error_log shows:
/usr/libexec/ld.so: httpd: libc-client.so.4.0: Invalid argument
If I do:
/usr/local/sbin/phpxs -r imap
Apache then works again.
I'm new at this.
Any help would be great...
Thanks,
Dave Miller
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=20942&edit=1