Bug #8744 Updated: call to header() causes CGI error

From: Date: Mon, 18 Mar 2002 22:15:59 +0000
Subject: Bug #8744 Updated: call to header() causes CGI error
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-2802@lists.php.net to get a copy of this message
ID: 8744 Updated by: php@gustl.at Reported By: emily@crytech.com Status: Critical Bug Type: IIS related Operating System: Windows 2000 PHP Version: 4.1.1 New Comment: I read your errors and found: FATAL: erealloc(): Unable to allocate 1043162510 bytes this seems to me like a MSSQL-PHP issue which comes along with the use of MSSQLs NTEXT and NVARCHAR Fields, after connecting to the MSSQL-database you must launch a SQL statement which limits the returning size fo this fields eg. 'SET TEXTSIZE 100000'. hope this helps Gustav Graf Previous Comments: ------------------------------------------------------------------------ [2002-03-14 06:52:39] stain@NOSPAM_studenti.it i noticed various problem working on header() function. in the worst case i get out a segmentation fault on my linux 2.4.4 running apache 1.3.22 + php 4.1.1 i will post a new bug thread about it in few minutes... bye, stain ------------------------------------------------------------------------ [2002-03-12 15:41:15] sabram@NO-SPAM.telus.net Hi All, I also have this problem and it is definately related to MSSQL because I also used the same code with a MySQL database and the error doesn't exist. Thanks, Steve ------------------------------------------------------------------------ [2002-02-16 05:20:10] imajes@php.net This problem also occurs when using apache, and a real url as opposed to a relative url (ie, having the php.exe engine exposed in the docroot). I cannot determine if it's the same cause, but it's definitely the same symptom. if this could get fixed, it'd fix a big security hole we have now. james. ------------------------------------------------------------------------ [2002-02-16 05:15:00] sander@php.net Reopening. ------------------------------------------------------------------------ [2002-02-15 18:24:04] michael@webmtj.com I have tried 4.1.1 with win2k and the bug still exists. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/8744 -- Edit this bug report at http://bugs.php.net/?id=8744&edit=1

« previous php.bugs (#2802) next »