#21161 [Com]: ./configure doesn't work with xslt support
| From: | h dot t dot d at gmx dot de | Date: | Mon, 23 Dec 2002 17:57:41 +0000 |
| Subject: | #21161 [Com]: ./configure doesn't work with xslt support | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-28290@lists.php.net to get a copy of this message | ||
ID: 21161
Comment by: h.t.d@gmx.de
Reported By: h.t.d@gmx.de
Status: Open
Bug Type: *Configuration Issues
Operating System: Linux Redhat 7.3
PHP Version: 4.3.0RC4
New Comment:
Hm - i told a lie, not the same configure command works on the other
release candidates, but a similar:
./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-pgsql=/usr
--with-gd=/usr/local --with-freetype-dir=/usr --with-jpeg-dir=/usr
--with-png-dir=/usr --with-zlib --enable-xslt --with-xslt-sablot=/usr
--enable-cli
the only difference on that machine is that i add gd2.0 to php. When i
run the configure command from my first post on that machine it wont
work in 4.2.3 and from 4.3.0RC1 to RC4 (see last post and ignore the it
works in RC2+RC3 comment;)).
i played around a bit on the other machines, but i wasn't able create a
useful xslt configure line.
It's strange that the first configure line fails on the machine where
xslt works. The second config line with gd2.0 and xslt works. When i
have time enough i will install gd2.0 on another machine and check
again.
Yours
HTD
Previous Comments:
------------------------------------------------------------------------
[2002-12-23 04:20:23] h.t.d@gmx.de
System:
Redhat 7.3
apache 2.0.43
postgresql 7.3
sablotron-0.96
expat-1.95.2-2
js-1.5rc4-2
When I configure using
./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-xslt=/usr
--enable-xslt-sablot=/usr --enable-sablot-js=/usr --with-pgsql
it get this output
checking whether to enable XML support... yes
checking external libexpat install dir... yes
checking for XMLRPC-EPI support... no
checking libexpat dir for XMLRPC-EPI... no
checking iconv dir for XMLRPC-EPI... no
checking whether to enable xslt support... yes
checking for XSLT Sablotron backend... yes
checking for libexpat dir for Sablotron XSL support... yes
checking for iconv dir for Sablotron XSL support... yes
checking for JavaScript for Sablotron XSL support... yes
configure: error: No backend specified for XSLT extension.
The same configure command worked on 4.3.0RC2 and RC3 on different
machines (all Redhat 7.3 though), but fails like shown above on all
machines using RC4. Also php4-STABLE-200212230830 creates that
message.
When i configure without the xslt options it works and builds, but
without xslt support of course ;)
Yours
HTD
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=21161&edit=1