#21216 [Opn->]: phpize passes --no-verify to ltconfig without specifying host

From: Date: Fri, 27 Dec 2002 18:03:52 +0000
Subject: #21216 [Opn->]: phpize passes --no-verify to ltconfig without specifying host
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-28487@lists.php.net to get a copy of this message
ID: 21216 Updated by: derick@php.net Reported By: jsheets@shadotech.com -Status: Open +Status: Won\'t fix Bug Type: *Configuration Issues Operating System: FreeBSD 4.7-STABLE PHP Version: 4.3.0 New Comment: PHP requires libtool 1.4 anyway, so the best thing would be to mail the FreeBSD maintainers again to update their software. Derick Previous Comments: ------------------------------------------------------------------------ [2002-12-27 11:25:58] jsheets@shadotech.com The phpize program creates a configure file that executes ltconfig with --no-verify but does not specify the host, FreeBSD ltconfig (libtool 1.3.4) requires the host be specified when the --no-verify parameter is passed, this results in the configure failing. When libtool 1.4 is installed the problem is resolved however 1.3.4 is what is in FreeBSD ports. This has been verified to be true with PHP 4.3.0 release on FreeBSD 4.7-STABLE with at least the curl, mhash and bz2 extensions. My configuration is as follows: AMD Athlon 1 GHZ CPU (686 class) FreeBSD 4.7 256 MB RAM Apache 1.3.27 PHP 4.3.0 Libtool: (GNU libtool) 1.3.4-freebsd-ports My PHP configuration line is: './configure' '--with-apxs=/usr/local/sbin/apxs' '--with-mcrypt' '--with-mhash' '--with-zlib' '--with-bz2' '--with-interbase' '--with-pdflib' '--with-gd' '--with-pgsql' '--with-mysql' '--enable-ftp' The output from the failed configure script is: loading cache /dev/null within ltconfig ltconfig: you must specify a host type if you use `--no-verify' Try `ltconfig --help' for more information. configure: error: libtool configure fail I manually installed libtool 1.4 and the problem went away, however the version of libtool in the FreeBSD ports collection is 1.3.4 so it is what most FreeBSD users will have installed. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=21216&edit=1

« previous php.bugs (#28487) next »