#21401 [NEW]: Apache doesn't start with php 4.3.0 php4ts.dll
| From: | michael at michael-kober dot de | Date: | Sat, 04 Jan 2003 00:42:12 +0000 |
| Subject: | #21401 [NEW]: Apache doesn't start with php 4.3.0 php4ts.dll | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-29029@lists.php.net to get a copy of this message | ||
From: michael@michael-kober.de
Operating system: Windows XP Professional
PHP version: 4.3.0
PHP Bug Type: Apache related
Bug description: Apache doesn't start with php 4.3.0 php4ts.dll
Windows XP Professional Service Pack 1, Apache 1.3.27, php 4.3.0 as
apache-modul, phplib + tomcat 3.3.1
testing apache: httpd.conf Syntax O.K.
But I can't start Apache with php 4.3.0
Starting Apache has as result only the Windows-Error-Massage: "Apache.exe
hat ein Problem festgestellt und muss beendet werden.", what means:
"Apache.exe has detected a problem and must be shut down"
Problemsignatur:
szAppName : Apache.exe szAppVer : 0.0.0.0 szModName : php4ts.dll
szModVer : 4.3.0.0 offset : 000af8ee
Files send to M$
C:\DOKUME~1\Michael\LOKALE~1\Temp\WERA.tmp.dir00\Apache.exe.mdmp
C:\DOKUME~1\Michael\LOKALE~1\Temp\WERA.tmp.dir00\appcompat.txt
If I substitute the php4ts.dll in C:\Windows\system32 with the "old"
4.2.3-version, everything works well, allthough the php.ini and all other
*.dll-files are version 4.3.0.
The failure is only with the php4ts.dll-file and Windows.
I have downloaded the Zip-file from another mirror, because I thought, the
file might be demaged. No result.
I think the failure is rather Windows ?? than php and reportet the failure
to M$ too.
Thanks for help. If there is no solution I work with the old version.
Michael.
--
Edit bug report at http://bugs.php.net/?id=21401&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=21401&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=21401&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=21401&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=21401&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=21401&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=21401&r=support
Expected behavior: http://bugs.php.net/fix.php?id=21401&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=21401&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=21401&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=21401&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=21401&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=21401&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=21401&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=21401&r=gnused