ID: 21310
User updated by: czuma@poland.org
Reported By: czuma@poland.org
Status: Open
Bug Type: *Directory/Filesystem functions
Operating System: Solaris 8
PHP Version: 4.3.0
New Comment:
Module PHP can't find files (eg. includes them) if HTTP server hasn't
permission to read all directories in path to the file.
Previous Comments:
------------------------------------------------------------------------
[2002-12-31 05:10:31] czuma@poland.org
After upgrading to 4.3.0 version some PHP scripts stop working. I have
checked, that the reason is problem with opening and including files.
FIRST EXAMPLE:
I had to change variable:
$blocked_list["kom.pl"] = "blockkom.txt";
--->
$blocked_list["kom.pl"] = "<full-path>blockkom.txt";
SECOND EXAMPLE:
-----------------------------------------------------------
Warning: main(main/linie.php) [function.main]: failed to create stream:
No such file or directory in /www/klient34/start/dolacz.php on line 5
Warning: main() [function.main]: Failed opening 'main/linie.php' for
inclusion (include_path=''.:..:/usr/local/lib/php'') in
/www/klient34/start/dolacz.php on line 5
------------------------------------------------------------
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=21310&edit=1