#21543 [Opn->Fbk]: unsupported field type errors with lvarchars
| From: | sniper@php.net | Date: | Fri, 10 Jan 2003 01:55:29 +0000 |
| Subject: | #21543 [Opn->Fbk]: unsupported field type errors with lvarchars | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-29647@lists.php.net to get a copy of this message | ||
ID: 21543
Updated by: sniper@php.net
Reported By: oliver.faenger@cityweb.de
-Status: Open
+Status: Feedback
Bug Type: Informix related
Operating System: All
PHP Version: 4.3.0
New Comment:
What is the output of 'esql -V' for you to require this?
The version detection works fine here..
(and what OS? Is it GNU sed you have there?)
Previous Comments:
------------------------------------------------------------------------
[2003-01-09 06:26:59] oliver.faenger@cityweb.de
lvarchars are not supported, because 'ext/informix/config.m4' gets a
wrong version number from 'esql -V'.
So HAVE_IFX_IUS is not set.
with this patch the problem should be solved:
--- php-4.3.0/ext/informix/config.m4.org 2003-01-09
11:15:07.000000000 +0100
+++ php-4.3.0/ext/informix/config.m4 2003-01-09 11:15:11.000000000
+0100
@@ -44,7 +44,7 @@
esac
AC_MSG_CHECKING([Informix version])
- IFX_VERSION=[`$INFORMIXDIR/bin/esql -V | sed -ne '1
s/^[^0-9]*\([0-9]\)\.\([0-9]*\).*/\1\2/p'`]
+ IFX_VERSION=[`$INFORMIXDIR/bin/esql -V | sed -ne '1 s/^.*Version
\([0-9]\)\.\([0-9]*\).*$/\1\2/p'`]
AC_MSG_RESULT($IFX_VERSION)
AC_DEFINE_UNQUOTED(IFX_VERSION, $IFX_VERSION, [ ])
Oliver
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=21543&edit=1