#13151 [Fbk->NoF]: /usr/lib/dld.sl: Can't shl_load() a library containing Thread Local Storage
| From: | sniper@php.net | Date: | Sat, 18 Jan 2003 04:08:29 +0000 |
| Subject: | #13151 [Fbk->NoF]: /usr/lib/dld.sl: Can't shl_load() a library containing Thread Local Storage | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-30434@lists.php.net to get a copy of this message | ||
ID: 13151
Updated by: sniper@php.net
Reported By: matteo.redaelli@pirelli.com
-Status: Feedback
+Status: No Feedback
Bug Type: OCI8 related
Operating System: HP-11
PHP Version: 4.0.6
New Comment:
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
Previous Comments:
------------------------------------------------------------------------
[2003-01-02 18:27:09] nicos@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-latest.zip
------------------------------------------------------------------------
[2002-09-19 05:35:25] fred@fred.net.nz
had this problem on HP-UX 11.0. try compiling with '-lcl' option, or
running apache with 'export LD_PRELOAD="/usr/lib/libpthread.sl:/
usr/contrib/oracle/lib/libjava.sl" ' in apachectl script.
Share and Enjoy! Fred
------------------------------------------------------------------------
[2002-04-12 06:05:45] cn@pinck.ch
I have the same Message when compiling
PHP 4.1.2 on HPUX 11.00 with
./configure --enable-libgcc
--with-apxs=/opt/apache/bin/apxs
--with-oci8=/ora_ovo/software/OraHome1
--enable-track-vars
The funny thing is that if I compile ADDITIONALLY with mysql support
(--with-mysql=/opt/mysql)
libphp4.so is about 2MByte SMALLER than without and fails to load as
well.
Compiling and starting Apache with MYSQL Support only works fine!
------------------------------------------------------------------------
[2001-09-05 10:26:22] matteo.redaelli@pirelli.com
Cannot start apache 1.3.20 & php 4.0.6 with --with-oci8 enabled:
bonnie.root./apps/WEB/sw $ /www/bin/apachectl start
/usr/lib/dld.sl: Can't shl_load() a library containing Thread Local
Storage: /usr/lib/libcl.2
/usr/lib/dld.sl: Exec format error
Syntax error on line 205 of /apps/WEB/apache/conf/httpd.conf:
Cannot load /apps/WEB/apache/libexec/libphp4.sl into server: Exec
format error
my configure options are:
CC=/opt/gcc/bin/gcc ./configure --prefix=/apps/WEB/php
--with-iconv=/opt/libicon
v --with-apxs=/apps/WEB/apache/bin/apxs --with-gd=shared
--with-gd=/opt/gd --wit
h-zlib-dir=/opt/zlib --with-ttf=/opt/freetype --without-mysql
--with-xpm-dir=/op
t/xpm --with-png-dir=/opt/libpng --with-gettext=/opt/gettext
--with-jpeg-dir=/
opt/jpeg-6 --enable-gd-native-ttf
--with-oci8=/oracle/PIRELLI/app/oracle/produc
t/8.0.5 --enable-sigchild
-------------------------
without oci8, GD libs are compiled successfully....
Matteo
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=13151&edit=1