#21681 [Opn->Csd]: Isapi/mssql crashes under high load !!!!

From: Date: Sun, 19 Jan 2003 00:38:02 +0000
Subject: #21681 [Opn->Csd]: Isapi/mssql crashes under high load !!!!
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-30531@lists.php.net to get a copy of this message
ID: 21681 Updated by: fmk@php.net Reported By: frusti@frusti.com -Status: Open +Status: Closed Bug Type: IIS related Operating System: Windows 2000 PHP Version: 4.3.0 New Comment: This is a problem with missing thread safety in the Microsoft libraries used to build the MSSQL extension. It can be used with ISAPI but you can only get a stable system when using cgi or fastcgi. The CGI error is not caused by either PHP or the MSSQL extension, but rather a problem with IIS. CGI processes are launched in forground, but the default setting for Windows NT/2000 is to optimize performence for background processes. If you switch this the CGI errors will go away. Previous Comments: ------------------------------------------------------------------------ [2003-01-18 14:29:39] frusti@frusti.com Sorry, I have also tested the latest snaps without any success! Can it give problems with connection when the MSSQL-Server is configurated with Network-protocols Named Pipes and TCP/IP ??? Have someone experience with it? Thanks and best regards, Andi ------------------------------------------------------------------------ [2003-01-17 20:53:10] sniper@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-STABLE-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-STABLE-latest.zip ------------------------------------------------------------------------ [2003-01-16 03:03:24] frusti@frusti.com sorry, have forgotten that just ISAPI is important!!! ------------------------------------------------------------------------ [2003-01-16 03:00:46] frusti@frusti.com ... ------------------------------------------------------------------------ [2003-01-16 02:51:26] frusti@frusti.com I have a large PHP-Application that must run under Windows. ;-) Tested under Windows with PHP 4.3.0: - IIS 5 with CGI - IIS 5 with ISAPI - Apache 2.0.43 with ISAPI Problems - witch CGI I have often problems with CGI-Error messages, but this problems are finished with ISAPI. - System runs fine but sometimes every client becomes warnings the "Unable to connect to server" or "Unable to select database xxxx". Under IIS an restart of IIS does nothing wright, just a reboot helps. Under Apache an restart of Apache release the problems. !!! Please see also Bug #20330 http://bugs.php.net/bug.php?id=20330 - its the same Problem!!!!!!! This can't be the solution? Have everbody a answer to that problem or have same problems? Thanks and best regards, Frast Andreas ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=21681&edit=1

« previous php.bugs (#30531) next »