#21812 [Fbk->Opn]: Apache crashes when require_once has array in directory name
| From: | pmoulding at tedis dot com dot au | Date: | Thu, 23 Jan 2003 04:40:06 +0000 |
| Subject: | #21812 [Fbk->Opn]: Apache crashes when require_once has array in directory name | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-31029@lists.php.net to get a copy of this message | ||
ID: 21812
User updated by: pmoulding@tedis.com.au
Reported By: pmoulding@tedis.com.au
-Status: Feedback
+Status: Open
Bug Type: Reproducible crash
Operating System: Win2000
PHP Version: 4.3.0
New Comment:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
20020123 is
working with just the default memory under Apache 2.0.44. Including
stacks of files, using Expat, XML, and creating gazillions of objects.
No errors so far.
Previous Comments:
------------------------------------------------------------------------
[2003-01-22 21:55:40] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
There was some memorylimit crash fixed recently
so please try the snapshot.
Anyway, about apache2..it's REALLY not ready for
production at ALL, especially with PHP.
Apache 1.3.27 is the best choice.
------------------------------------------------------------------------
[2003-01-22 21:53:00] pmoulding@tedis.com.au
When I opened the error report, I did not know the error could be
deferred by adding more memory. Now that I know the extra memory defers
the problem, I can allocate extra memory.
Allocating extra memory might not be practical for all people
especially those with hosted sites where the ISP restricts php.ini
changes.
Crashing Apache is also bad form. I know Apache 2 is considered new.
Anything newer than Apache release 1.0.1 is too new for some people. A
lot of people now use Apache 2 on production servers and PHP 4.3.0 must
be bullet proof in that environment by now.
I will upgrade to Apache 2.0.44 then test using just 8 Mb and see if
the problem occurs. If someone out there knows of compatibility and
stability issues with Apache 2, they might like to suggest the best
release for use with PHP 4.3.0. I have downloads 2.0.39, 2.0.43, and
2.0.44.
------------------------------------------------------------------------
[2003-01-22 21:35:00] sniper@php.net
So what's the bug here? If you run out of memory, how can
that be a PHP bug? :)
------------------------------------------------------------------------
[2003-01-22 17:44:35] pmoulding@tedis.com.au
The require_once error has not occurred when using 80Mb.
The original require structure ended up including every component in
the system. I added a few if statements to include only those
components required for the script. The original mess might have used
up the default 8Mb of memory. My clean version probably uses less than
1 Mb for my code.
I am using the PHP binary compiled with all options. I think that comes
to about 4 Mb. If that 4 Mb is loaded in to the default 8Mb when
running PHP as a module then my original code would have easily used
the remaining 4 Mb. Changing the allocation to 80Mb may have, in
effect, increased available memory from 4 Mb to 76 Mb.
------------------------------------------------------------------------
[2003-01-22 17:28:25] moriyoshi@php.net
Has the change on memory_limit entry solved the require_once problem
too?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/21812
--
Edit this bug report at http://bugs.php.net/?id=21812&edit=1