#21863 [Opn->Fbk]: PHP as SAPI under IIS brings down all web services trying to find php_mhash.dll
| From: | iliaa@php.net | Date: | Fri, 24 Jan 2003 17:15:43 +0000 |
| Subject: | #21863 [Opn->Fbk]: PHP as SAPI under IIS brings down all web services trying to find php_mhash.dll | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-31157@lists.php.net to get a copy of this message | ||
ID: 21863
Updated by: iliaa@php.net
Reported By: fishrunsrap@hotmail.com
-Status: Open
+Status: Feedback
Bug Type: Reproducible crash
Operating System: windows
PHP Version: 4.3.0
New Comment:
Do you get an error loading php_mhash.dll with the CLI sapi?
Previous Comments:
------------------------------------------------------------------------
[2003-01-24 11:05:34] fishrunsrap@hotmail.com
IIS hangs when starting up with PHP 4.3.0 running as a SAPI module if I
try to load php_mhash.dll as an extension. The event viewer gives the
following message, classified as 'Information':
Application popup: Warning : Unknown(): Unable to load dynamic library
'D:\php-4.3.0-Win32\extensions\php_mhash.dll' - The specified module
could not be found.
... the World Wide Web Publishing Service then freezes, saying it's
'starting'. it does not respond to control messages from either 'net
stop' on the command line or other GUI controls.
this is a bug because no other extensions fail in this manner, and
they're all in the same place, and everything works just fine with
exactly the same setup with PHP 4.2.3, also running in IIS as a SAPI.
-fish
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=21863&edit=1