Bug #14865 Updated: php4apache.dll - phpinfo error - winXP - Apache

From: Date: Fri, 22 Mar 2002 05:24:27 +0000
Subject: Bug #14865 Updated: php4apache.dll - phpinfo error - winXP - Apache
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-3120@lists.php.net to get a copy of this message
ID: 14865 Updated by: mvirtue@zip.com.au Reported By: p.wenger@gmx.ch Status: Open Bug Type: Apache related Operating System: Win XP Prof PHP Version: 4.1.1 New Comment: Another instance: I have a page that only contains <? phpinfo(); ?> and nothing else. PHP ver: 4.1.2 Machine: WinXP Pro HTTPD: Apache, PHP as a module When I browse to the page on my local machine (localhost) I get strange behaviour. I get a large number of instant redirects - in other words, the browser sits there redirecting itself to the same page for about 10 seconds (maybe 50 redirects in all). Finally the page either displays properly, or I get a DNS server not found error page in my browser. It's only started doing this since I upgraded from 4.0.6 to 4.1.2. I have just installed 4.2.0 RC1, but it makes no difference. If I go back to 4.0.6, it's fine. You can try this yourself. Go to: http://mvirtue.myip.org/test/index.php and see what you get. I got a friend of mine to try it from his machine, and he briefly saw the first few lines of the PHP info screen, and then was instantly redirected to a DNS error page. Often the page displays perfectly the first time you go there. It's only when you hit "Refresh" do you get the bizarre behaviour. Previous Comments: ------------------------------------------------------------------------ [2002-01-18 08:50:59] p.wenger@gmx.ch How I can get the new version? I tried to found by http://cvs.php.net/cvs.php/php4/win32 but I couldn't find the binary-Version for win32! Can you send me the new version or say me where I can find it? I don't beleve, that the but is fix, why the problem was not only with the verion 4.1.1, it was with 4.0.6 too! Greats Pascal ------------------------------------------------------------------------ [2002-01-11 10:43:45] xe@xemi.info This problem occurs only on WIN XP (Pro?) as an OS. ------------------------------------------------------------------------ [2002-01-11 10:41:12] xe@xemi.info As for me - i don't have any extension except imap&gd installed. Maybe something else? I found the same problem with phpmyadmin - it shows "could not found server" page in left frame (the one with database/tables list) from time to time. Ivan ------------------------------------------------------------------------ [2002-01-11 10:28:43] sander@php.net There was a problen with phpinfo in 4.1.x when the zlib-extension was enabled. That bug has been fixed, you can try the latest CVS to see if it also fixes this bug. ------------------------------------------------------------------------ [2002-01-10 03:38:20] xe@xemi.info I've got the same problem. Same OS, same PHP, same problem. It really bothers me only when PHP is installed as an Apache module. Does anybody have the solution? Ivan ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/14865 -- Edit this bug report at http://bugs.php.net/?id=14865&edit=1

« previous php.bugs (#3120) next »