#12061 [Com]: CGI Error

From: Date: Sat, 25 Jan 2003 04:11:49 +0000
Subject: #12061 [Com]: CGI Error
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-31201@lists.php.net to get a copy of this message
 ID:               12061
 Comment by:       ecorriel@hotmail.com
 Reported By:      peters@connection.ca
 Status:           Bogus
 Bug Type:         IIS related
 Operating System: Win 2K
 PHP Version:      4.0.6
 New Comment:

regarding the entry: [24 Apr 2002 10:37am] afirato@hotmail.com

this is not a bug, you are just using dlls from previous versions of
PHP. get the new dlls and overwrite the old ones.  i just posted a note
about this under the Installation for Windows section of the Manual.


Previous Comments:
------------------------------------------------------------------------

[2003-01-05 04:09:32] wyared@yahoo.com

I was facing this problem when writing a code on the w9x Notepad and
modifying it by win2k editors or viseversa ... seems to be a problem
converting between unicode and ASCII.. in my humble openion (donno if
it's even right!) do it all on one editor.

------------------------------------------------------------------------

[2003-01-02 09:12:54] codingforums@couchfort.org

I have the same problems with phpmyadmin producing a CGI error in both
panes after locking the anonymous IIS user out of the phpmyadmin
directory. I provide a credentials for a user with proper permissions
to that folder when accesssing it, but I still get the CGI errors. I
don't think it's reasonable to grany anonymous users access to this
administrative tool...

Any ideas?

------------------------------------------------------------------------

[2002-10-22 08:14:01] JoeHa@gmx.de

I had this error when I use php myAdmin.

The problem was:
I had edit the config.inc.php with wordpad.

The sollution:
editing with textPad

...so long, Joe

------------------------------------------------------------------------

[2002-10-16 16:10:48] dnocito@accelesoft.com

I have W2k Server IIS5/PHP4
I was able to fix this issue simply by doing the following:

Open Internet Service Manager
Right Click Default Web Site (or any website using php)
Goto Properties
Click the HOME DIRECTORY tab
Click the CONFIGURATION button
Scroll down the list and select .php
Click Edit button
enable the CHECK THAT FILE EXISTS checkbox.
ok your way out.

This eliminated my problems with this error.

------------------------------------------------------------------------

[2002-08-24 12:08:29] poser187@hotmail.com

For those of you getting a CGI ERROR when trying to run PHPmyAdmin from
IIS (e.g. http://localhost/path_to_your_phpmyadmin_install/
 .. 
Look at your config.inc file under "$cfg['PmaAbsoluteUri'] = " and make
sure that you have not included and extra space between the ending /
and the closing quotation mark.
Do this: ... ='http://localhost/phpmyadmin/'
Not This: ... ='http://localhost/phpmyadmin/  '
If this is the cause of your problem you will see a /%20%/ between
localhost and /phpmyadmin. All that is happening is an extra space is
being input into your html. Simple fix. Hope this helps some of you.

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
    http://bugs.php.net/12061

-- 
Edit this bug report at http://bugs.php.net/?id=12061&edit=1



Thread (1 message)

  • ecorriel at hotmail dot com
  • Unknown Message
    • ecorriel at hotmail dot com
« previous php.bugs (#31201) next »