#21897 [Com]: ORA-03113: end-of-file on communication channel

From: Date: Mon, 27 Jan 2003 18:37:41 +0000
Subject: #21897 [Com]: ORA-03113: end-of-file on communication channel
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-31355@lists.php.net to get a copy of this message
ID: 21897 Comment by: michael.mauch@gmx.de Reported By: mbretter@php.net Status: Open Bug Type: OCI8 related Operating System: Solaris PHP Version: 4.2.3 New Comment: Make sure you set the environment variables mentioned on <http://de3.php.net/manual/de/ref.oci8.php> before you start your httpd. _Don't_ set them in PHP with putenv() or in httpd.conf with SetEnv. If this doesn't help, maybe you can find the cause of the problem by reading <http://www.oracle-error.com/ora-03113.htm>. Previous Comments: ------------------------------------------------------------------------ [2003-01-27 04:24:39] mbretter@php.net This error occurs very often but not allways: FEHLER: Database error: ALTER SESSION SET NLS_DATE_FORMAT="YYYY-MM-DD HH24:MI:SS" Oracle8 Error: O (ORA-03113: end-of-file on communication channel ) Session halted. Warning: failed to rollback outstanding transactions!: ORA-03114: not connected to ORACLE in Unknown on line 0 it seems that the Oracle connection died, but the oci8 extension doesen't know this. The sql-statement above is the first after OCIPlogon(), changing to OCINLogon() doesen't solved this problem. We run the same application on other platforms with Oracle without any problems, this problem seems to be Solaris related. The Oracle Version is 8.1.7.4. Apache 1.3.26. The problem also occurs with PHP4.1.1 ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=21897&edit=1

« previous php.bugs (#31355) next »