#22304 [Opn->Bgs]: imap_sort fails when c-client >=2002 and SE_UID and imapserver has no SORT-cap
| From: | sniper@php.net | Date: | Thu, 20 Feb 2003 07:56:20 +0000 |
| Subject: | #22304 [Opn->Bgs]: imap_sort fails when c-client >=2002 and SE_UID and imapserver has no SORT-cap | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-33651@lists.php.net to get a copy of this message | ||
ID: 22304
Updated by: sniper@php.net
Reported By: Joerg dot Dieter dot Friedrich at uni-konstanz dot de
-Status: Open
+Status: Bogus
Bug Type: IMAP related
Operating System: Solaris 8
PHP Version: 4.3.1
New Comment:
You should report this to the c-client author since this
is not PHP bug.
Previous Comments:
------------------------------------------------------------------------
[2003-02-19 15:40:31] Joerg dot Dieter dot Friedrich at uni-konstanz
dot de
Hi!
I encountered following problem:
imap_sort returns an empty array if all of
the following criteria are satisfied:
1. php_imap is linked against libc-client.a >= 2002
2. the imapserver has no SORT capability
here former iPlanet now SunOne<blabla> imapserver
3. request from imap_sort to return UIDs with SE_UID
I was told that this problem does not encounter on Linux, but I cannot
confirm this. And I had no time to test php prior to 4.3.0.
php compiled against | imap_sort(...,SE_UID)
imap-2001a w/o ssl | works
imap-2001a w/ ssl | works
imap-2002b w/o ssl | doesn't works
imap-2002b w/ ssl | doesn't works
imap-2003-dev w/o ssl | doesn't works
imap-2003-dev w/ ssl | doesn't works
I switched back to imap-2001a, but I hope this can be resolved.
Yours Jörg
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=22304&edit=1