#22324 [Fbk]: Configure failure
| From: | sniper@php.net | Date: | Fri, 21 Feb 2003 09:08:18 +0000 |
| Subject: | #22324 [Fbk]: Configure failure | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-33788@lists.php.net to get a copy of this message | ||
ID: 22324
Updated by: sniper@php.net
Reported By: j dot lammerts at chello dot nl
Status: Feedback
Bug Type: OCI8 related
Operating System: AIX 4.3.3
PHP Version: 4.3.2-dev
New Comment:
Have you set the LIBPATH and LD_LIBRARY_PATH correctly
as mentioned in the Oracle installation notes?
To point to $ORACLE_HOME/lib
Previous Comments:
------------------------------------------------------------------------
[2003-02-21 03:01:18] sniper@php.net
Duh..nevermind..you mentioned those in your first comment..
------------------------------------------------------------------------
[2003-02-21 02:54:27] sniper@php.net
Where is libocijdbc8 in your system?
------------------------------------------------------------------------
[2003-02-21 02:50:52] j dot lammerts at chello dot nl
With all due respect, the "bad filenumber" bug has been fixed in CVS,
but the first bug I mentioned hasn't.
After configuration I still see in the debug.log that ld is not able to
open library file -l ocijdbc8.
Notice the space between -l and ocijdbc8. Might just be the way of
AIX's ld to show things. The LIBS variable does look OK : .......-lld
-lclntsh -locijdbc8
Could someone please look into this again ?
Thank you.
------------------------------------------------------------------------
[2003-02-20 07:24:06] sniper@php.net
This bug has been fixed in CVS.
In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.
------------------------------------------------------------------------
[2003-02-20 06:08:39] j dot lammerts at chello dot nl
By the way,
At the end of config I get the following :
+--------------------------------------------------------------------+
./config.status[1400]: 6: bad file unit number
./config.status[1401]: 6: bad file unit number
X
echo """" 1>&6
echo """^[[1mThank you for using PHP.^[[m" 1>&6
cat<<X
X
Seem to remember that this was resolved for AIX...
Back in error again ?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/22324
--
Edit this bug report at http://bugs.php.net/?id=22324&edit=1