#22417 [NEW]: Error while using sessions with MM
| From: | juliano at cyberweb dot com dot br | Date: | Tue, 25 Feb 2003 19:23:37 +0000 |
| Subject: | #22417 [NEW]: Error while using sessions with MM | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-34249@lists.php.net to get a copy of this message | ||
From: juliano at cyberweb dot com dot br
Operating system: Linux RH 7.3
PHP version: 4.3.1
PHP Bug Type: Apache related
Bug description: Error while using sessions with MM
I had a fast experience to increase the performance of PHP scripts in about
100%. Fast, but unhappy. The problem is the following one: when using PHP
with Sessions being recorded dinamicaly with module MM
(session.save_handler = mm), after some minutes of activities (about
executed hundreds of scripts), start to appear ackward messages in
apache's error_log, as:
[ Tue Feb 25 15:45:14 2003 ] [ notice ] child pid 1340 exit signal
Segmentation fault (11)
... and in few minutes later, apache crashes.
Some solution? I'm looking for and I did not find nothing... I arrived to
read something about create the file /tmp/session_mm.sem but... the
problem continues repeating.
Unhappyly I had that to come back toward the traditional method, using
files.
I don't know if this problem is on PHP, Apache or MM, but.. I know it only
appears when I change the method of sessions be saved.
InfoI had the fast experience to obtain to increase the performance of the
PHP in a server in about 100%. Fast, but unhappy. The problem is the
following one: when using PHP with Sessions being recorded dinamicamente
with module MM (to session.save_handler = mm), after some minutes of
activities (about executed hundreds of scripts), start to appear ackward
messages as:
[ Tue Feb 25 15:45:14 2003 ] [ notice ] child pid 1340 exit signal
Segmentation fault (11)
... and in few minutes later, apache crashes.
Some solution? I looked for in the InterNet and I did not find nothing...
I arrived to read something it type to create the archive
in/tmp/session_mm.sem but... the problem continues if repeating.
Unhappyly I had that to come back toward the traditional method, using
files.
Using: Apache 1.3.27, PHP 4.3.1 and MM 1.2.2
Juliano Primavesi
CyberWeb Networks
--
Edit bug report at http://bugs.php.net/?id=22417&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=22417&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=22417&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=22417&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=22417&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=22417&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=22417&r=support
Expected behavior: http://bugs.php.net/fix.php?id=22417&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=22417&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=22417&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=22417&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=22417&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=22417&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=22417&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=22417&r=gnused