#22759 [Opn->Csd]: symbol dn_skipname: referenced symbol not found
| From: | sniper@php.net | Date: | Tue, 18 Mar 2003 17:47:01 +0000 |
| Subject: | #22759 [Opn->Csd]: symbol dn_skipname: referenced symbol not found | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-35851@lists.php.net to get a copy of this message | ||
ID: 22759
Updated by: sniper@php.net
Reported By: silent at host dot sk
-Status: Open
+Status: Closed
Bug Type: Apache related
Operating System: Solaris 8
PHP Version: 4.3.1
New Comment:
This bug has been fixed in CVS.
In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.
Previous Comments:
------------------------------------------------------------------------
[2003-03-18 05:16:06] silent at host dot sk
Hello.
I had a problem running Apache with PHP module.
Apache and PHP compiles without any error, but if I enable the PHP
module, I get this error message:
# /usr/local/apache/bin/apachectl start
Syntax error on line 236 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/libphp4.so: symbol dn_skipname: referenced
symbol not found
/usr/local/apache/bin/apachectl start: httpd could not be started
Apache works without PHP module fine, but with PHP module not.
I found in the PHP configure script log these two lines:
checking for dn_skipname in -lresolv... no
checking for __dn_skipname in -lresolv... yes
It looks like the compiled PHP module still uses dn_skipname instead of
__dn_skipname. It is maybe a 'configure' script error. I found in dns.c
a function call to dn_skipname, so I have change it from dn_skipname to
__dn_skipname and then run 'make' and 'make install'
Now runs Apache with PHP module.
PHP configure line:
# ./configure --with-mysql --with-apxs=/usr/local/apache/bin/apxs
Apache configure line:
# ./configure --enable-shared=max --enable-module=most
my system: Solaris 8 on Sun Ultra1
some system information:
# $PATH
/usr/local/bin:/usr/bin:/usr/local/ssl/bin:/usr/local/mysql/bin:/apache/bin:/opt/sfw/bin:/usr/sbin:/usr/dt/bin:/usr/openwin/bin:/bin:/usr/ucb
# LD_LIBRARY_PATH
/usr/local/lib:/lib:/usr/lib:/usr/local/ssl/lib:/usr/include:/usr/local/include:/usr/local/mysql/lib:/usr/local/lib/gcc-lib:/usr/local/lib/gcc-lib/sparc-sun-solaris2.8/3.2.1:/opt/sfw/lib:/opt/sfw/include
installed patches: 8_Recommended from 17.01.2003; + 108995-04,
109025-04, 109234-09, 111295-01, 111297-01
development tools:
gcc 2.95.3 or 3.2.1
binutils 2.11.2
automake 1.5 or 1.7.2
autoconf 2.13 or 2.57
libtool 1.4
bison 1.75
flex 2.5.4a
gawk 3.1.0
m4 1.4
make 3.80
sed 4.0
textinfo 4.2
zlib 1.1.4
I don't know if this solution is correct, but it works.
This bug is in older versions too, I tryed versions 4.1.1, 4.2.3,
4.3.0, 4.3.1
Bye
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=22759&edit=1