#22794 [Bgs]: Apache fails to start, and produces no error
| From: | spoon at nexdot dot net | Date: | Thu, 20 Mar 2003 12:13:24 +0000 |
| Subject: | #22794 [Bgs]: Apache fails to start, and produces no error | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-36032@lists.php.net to get a copy of this message | ||
ID: 22794
User updated by: spoon at nexdot dot net
Reported By: spoon at nexdot dot net
Status: Bogus
Bug Type: Apache2 related
Operating System: windows 2000 server
PHP Version: 4CVS-2003-03-19 (stable)
New Comment:
My 'dev' is pre rc1.
Previous Comments:
------------------------------------------------------------------------
[2003-03-19 21:38:45] ianh@php.net
hi.
I'm a bit confused
the 'dev' version you are working with is the most current snapshot? or
a older one (when from)
you wouldn't have the window debugger available would you?
------------------------------------------------------------------------
[2003-03-19 20:30:46] spoon at nexdot dot net
I have php4apache2.dll as the module that is being loaded on both
machines...
(if that is what you mean.... otherwise, there is no apache2handler.dll
if _that_ is what you mean)
------------------------------------------------------------------------
[2003-03-19 18:04:22] sniper@php.net
It's now by default using the sapi/apache2handler.
Make sure your httpd.conf is configured properly.
------------------------------------------------------------------------
[2003-03-19 17:59:58] spoon at nexdot dot net
This has happened with a few of the cvs versions (i try a few times a
week with latest stable snapshots) ever since RC1 was released
(4.3.2).
After appropriatley installing php (like usual) apache will fail to
start, and will produce no error on stdout, nor will it log anything
(unusual) in the apache error log besides its normal child process info
when it kills itself.
When i put back the php i had before it (4.3.2-dev according to php
-v), it works fine. I enabled error logging in RC1-cvs and no log was
produced during the failed apache starts.
I can reproduce this on 2 different server, one running Windows 2000
Server (the case im reporting), and on my home server running Windows
XP RC1. Both work on 4.3.2-dev, and fail on 4.3.2-RC1.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=22794&edit=1