#19599 [Com]: "driver initialization failed" on any "driver"
| From: | b0nks at nerim dot net | Date: | Tue, 25 Mar 2003 14:27:11 +0000 |
| Subject: | #19599 [Com]: "driver initialization failed" on any "driver" | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-36390@lists.php.net to get a copy of this message | ||
ID: 19599
Comment by: b0nks at nerim dot net
Reported By: ivoras at fer dot hr
Status: Bogus
Bug Type: DBM/DBA related
Operating System: Linux (Debian 3)
PHP Version: 4.2.3
Assigned To: helly
New Comment:
well, its the same using "--enable-flatfile" with ndbm enabled or not
ivoras, another program is creating the database, so i can't change the
file structure..
Previous Comments:
------------------------------------------------------------------------
[2003-03-13 15:05:43] ivoras at fer dot hr
Just to add, this was NOT a bogus report, and the problem was visible
on many systems, including FreeBSD. There IS something fishy going on
with the DBA module, no the least with the (absence/improper use) of
record locking. My final solution was to use a custom PHP-written flat
file system, until all is solved.
------------------------------------------------------------------------
[2003-03-13 14:09:19] helly@php.net
With flatfile i mean "--enable-flatfile"
However do you use lib-d2.a or .so?
In case of .a use the .so (it may be necessary to recompile db2 with
"--enable-shared"). To test this use
"ldd php".
------------------------------------------------------------------------
[2003-03-13 08:52:10] b0nks at nerim dot net
actually i have db2 support enabled and it does not work at all, i'll
try and tell you what the result is without ndbm enabled.
what do you mean "enabling flatfile"?
Did another test: on a RedHat 8 / PHP 4.3.1
same result
------------------------------------------------------------------------
[2003-03-10 17:12:38] helly@php.net
For a first start please only use db2 OR db3 support.
If this doesn't help disable ndbm also. Then enable flatfile and see if
this works.
Since you cannot have both db2 and db3 enabled this stays bogus.
------------------------------------------------------------------------
[2003-03-10 03:00:42] b0nks at nerim dot net
I got the same error whatever dba_* function i use: i have tested on
Windows XP / PHP 4.2.0
Linux GNU Debian / PHP 4.1.2
Linux GNU Debian / PHP 4.3.1
dba support is enabled in all versions refering to phpinfo();
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/19599
--
Edit this bug report at http://bugs.php.net/?id=19599&edit=1