#22916 [Opn->Bgs]: Make install fails due a apxs error
| From: | iliaa@php.net | Date: | Thu, 27 Mar 2003 13:45:16 +0000 |
| Subject: | #22916 [Opn->Bgs]: Make install fails due a apxs error | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-36571@lists.php.net to get a copy of this message | ||
ID: 22916
Updated by: iliaa@php.net
Reported By: alietss at yahoo dot com
-Status: Open
+Status: Bogus
Bug Type: Apache2 related
Operating System: Openna Linux RC2
PHP Version: 4CVS-2003-03-26 (stable)
New Comment:
Sorry, but your problem does not imply a bug in PHP itself. For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system
is not the
appropriate forum for asking support questions.
Thank you for your interest in PHP.
apxs, which is an apache tool cannot find your httpd.conf (apache
configuration) this is hardly a PHP problem.
Previous Comments:
------------------------------------------------------------------------
[2003-03-26 21:49:45] alietss at yahoo dot com
Hi boys:
I'm building rpms for openna Linux of php-4.3.2 current sources from
snaps.php.net everything was going ok but the install fails with this
erro...
Installing PHP SAPI module
/usr/lib/httpd/build/instdso.sh
SH_LIBTOOL='/usr/lib/httpd/build/libtool' libphp
4.la /var/tmp/php-4.3.2-root/usr/lib/httpd/modules
/usr/lib/httpd/build/libtool --mode=install cp libphp4.la
/var/tmp/php-4.3.2-roo
t/usr/lib/httpd/modules/
cp .libs/libphp4.so
/var/tmp/php-4.3.2-root/usr/lib/httpd/modules/libphp4.so
cp .libs/libphp4.lai
/var/tmp/php-4.3.2-root/usr/lib/httpd/modules/libphp4.la
libtool: install: warning: remember to run `libtool --finish
/usr/src/openna/BUI
LD/php-4.3.2/libs'
chmod 755 /var/tmp/php-4.3.2-root/usr/lib/httpd/modules/libphp4.so
apxs:Error: Config file
/var/tmp/php-4.3.2-root/etc/httpd/conf/httpd.conf not fo
und.
make: *** [install-sapi] Error 1
With php-4.3.1 the build was ok, this is my configure line...
%configure \
--prefix=%{_prefix} \
--with-layout=GNU \
--with-config-file-path=%{_sysconfdir}/httpd \
--with-apxs2=%{_sbindir}/apxs \
--with-exec-dir=%{_bindir} \
--with-openssl \
--with-zlib \
--with-bz2 \
--with-gd \
--with-ttf \
--with-png \
--with-jpeg-dir=%{_prefix} \
--with-png-dir=%{_prefix} \
--with-freetype-dir=%{_prefix} \
--with-expat-dir=%{_prefix} \
--with-gmp \
--with-xml \
--with-curl \
--with-mm \
--with-imap=shared \
--with-imap-ssl \
--with-pspell \
--with-gettext \
--with-mysql=shared,%{_prefix} \
--with-mysql-sock=/var/lib/mysql/mysql.sock \
--with-pgsql=shared \
--with-ldap=shared \
--with-pear \
--disable-static \
--disable-debug \
--disable-rpath \
--disable-posix \
--disable-tokenizer \
--enable-discard-path \
--enable-safe-mode \
--enable-magic-quotes \
--enable-bcmath \
--enable-dio \
--enable-gd-native-ttf \
--enable-sysvsem \
--enable-sysvshm \
--enable-sockets \
--enable-track-vars \
--enable-wddx \
--enable-inline-optimization \
--enable-memory-limit
Any Ideas, Aliet
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=22916&edit=1