#22787 [Bgs->Opn]: Make fails after upgrading to mysql v4.0.12

From: Date: Mon, 07 Apr 2003 12:05:23 +0000
Subject: #22787 [Bgs->Opn]: Make fails after upgrading to mysql v4.0.12
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-37263@lists.php.net to get a copy of this message
ID: 22787 User updated by: gregory dot fennell at am dot sony dot com Reported By: gregory dot fennell at am dot sony dot com -Status: Bogus +Status: Open Bug Type: MySQL related Operating System: RedHat v8.0 PHP Version: 4.3.1 New Comment: OK, I will try this one more time. As several postings have confirmed, this is an issue. Can someone please work on a fix so that we can move forward with using the newest production releases of PHP? It seems that two postings from "azza at sbcglobal dot net" didn't get posted or were removed so I am reposting them. Posting #2: I am unclear why this has been set to bogus vs open. (1) A significant number of other parties are having this issue. (2) The failure to reproduce the error does not mean the error does not exist. (3) The installation process for php and mysql is quite varied, thus unlesss one tests all major installation scenarios no conclusion may be drawn. (4) As shown in my previous post - several rpms show a requirement of libmysqlclient.so.10. The correction is to use libmysqlclient.so which has a symlink to the current version, which is libmysqlclient.so.12. Thus, a) the bug is not bogus, b) the correction may be simple and c) failure to correct the error may have significant negative consequences. Posting #1: Same Issue: I agree that working together is the means for resolving this issue. (1) php-mysql-4.3.1-rbt.rh8.1.i386.rpm shows requirement of libmysqlclient.so.10 http://www.aucs.org/rpmcenter/details/php-4.3.1-for-apache-1.3.x/php-mysql-4.3.1-rbt.rh8.1.i386.rpm.html (2) php-mysql-4.2.2-8.0.7 RPM for i386 shows requirement of libmysqlclient.so.10 http://rpmfind.net/linux/RPM/redhat/updates/8.0/i386/php-mysql-4.2.2-8.0.7.i386.html What should be in the code is a reference to libmysqlclient.so which is a symlink to the current version - libmysqlclient.so.12. This may be a major issue if it crashes a large number of sites. Take a look at how libmyssqlclient.so is configured on your system. Previous Comments: ------------------------------------------------------------------------ [2003-04-04 10:57:34] sniper@php.net Did you uninstall the old mysql 3.23 version before installing that new one? Are you sure it's not just a conflict between old and new version of mysql? And I say again: This is NOT any bug in PHP. Please ask further support questions on e.g. php-install@lists.php.net ------------------------------------------------------------------------ [2003-04-04 07:15:37] gregory dot fennell at am dot sony dot com The following RPMs are used (Version: 4.0.12): Server Client programs Libraries and header files Dynamic client libraries I also use a self-compiled version of PHP-4.3.1 with the configure line that is in my original posting. Any help you can give is greatly appreciated. I know I have several colleagues that are waiting on a fix as well. Thanks for your help in this. ------------------------------------------------------------------------ [2003-04-03 19:48:38] sniper@php.net Which RPMs have you installed? You need to have the libraries and header files installed too to get the build work.. ------------------------------------------------------------------------ [2003-04-03 07:09:47] gregory dot fennell at am dot sony dot com Sniper, I understand that it works for you. But you stated you are using the latest CVS and self compiled MySQL. That is not the original issue and I want to stay on track. The issue is that the RPM installation of MySQL will not work with the self-compiled version of PHP. Two people have posted to this saying they are having the same issue, but you insist on saying this is bogus. I will not use a CVS version on production machines, nor should anyone. So what do we need to do so that you will take this issue seriously? I thought the purpose of open source products was for people to work together to make a product better, but in this case it seems our needs to make the product better are being ignored. ------------------------------------------------------------------------ [2003-04-02 18:56:37] sniper@php.net Works fine here, with latest CVS snapshot and self compiled Mysql 4.0.12. Try with shorter configure line, maybe something else is causing the problem. (like this: ./configure --disable-all --with-mysql=/usr) ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/22787 -- Edit this bug report at http://bugs.php.net/?id=22787&edit=1

« previous php.bugs (#37263) next »