#12975 [Com]: Unable to load dynamic library 'd:\applications\php\extensions\php_oci8.dll' -
| From: | mikeDONTspamORjunkME at webheat dot co dot uk | Date: | Wed, 09 Apr 2003 11:30:50 +0000 |
| Subject: | #12975 [Com]: Unable to load dynamic library 'd:\applications\php\extensions\php_oci8.dll' - | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-37420@lists.php.net to get a copy of this message | ||
ID: 12975
Comment by: mikeDONTspamORjunkME at webheat dot co dot uk
Reported By: pbabilotte at multilignes dot fr
Status: Bogus
Bug Type: IIS related
Operating System: Windows 2000 Server
PHP Version: 4.0.6
New Comment:
I have the same issue.
I have just tried a little test. I added an 'extension' of a file
already existing in my extensions dir, which just so happened to be
wupdmgr.exe - Windows Update Manager.
I commented back out the other extension I WAS trying to load and
revisted a php page on my server.
NO ERROR.
So I matched the security settings between the files identically and
uncommented the extension I was trying to load php_gd2.dll.
ERROR again!
So it seems that it's not so much where you put the file or what the
acls on it are, more the file itself has issues.
Some documentation on this issue from the PHP bods would not go amiss
on this.
:)
Previous Comments:
------------------------------------------------------------------------
[2002-06-02 15:14:34] k.schroeder@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php
Thank you for your interest in PHP.
------------------------------------------------------------------------
[2002-05-22 11:26:04] tobias-nitsche at gmx dot net
I've got the same problem on an iis 4.0 (windows nt) and iis 5.0
(windows 2000), this problem happens always and it doesen't which
library I want to load with php...
Can anybody help me?? I need the libraries...
------------------------------------------------------------------------
[2002-05-13 15:19:24] hnek at nepadresje dot nep dot nl
Hello,
I have similar problems on Win2k-server and WinXP when trying to get
php_gd working. This dll-loading seems magical stuff.
First I got this 'specified procedure'-error only at work. The
configuration there: php_gd.dll/PHP4.0.6/IIS/Win2k. But I didn't have
any problem at home with configuration:
php_gd.dll/PHP4.0.6/Xitami/WinXP. So I tried to get me a new
PHP-version, 4.2, to test with at home. And you won't believe it...
with a configuration: php_gd.dll/PHP4.2/Xitami/WinXP, now I get the
'specified
procedure'-error at home. By the way, I got rid of the
'module-not-found' by typing the right path c:/php/ex... with all
foward-slashes.
Once I was a happy php_gd-user. Now feel like a
Windoze-looser.
h e l p
Mark
------------------------------------------------------------------------
[2002-02-26 18:01:33] info at tmnd dot de
Hello,
I also have a similar problem.
I am using with php4ispi.dll with IIS5 Win2000 Prof..
I wrote my own extension in a dll.
And it can load it, that means, I can run phpinfo() so that
it shows my Extension. But I cannot run the functions which are
implemented in this extension.
And I also cannot run a simple application.
------------------------------------------------------------------------
[2002-01-16 12:43:06] habeck at gmx dot de
IMO it's not only the php_oci8.dll which cannot be loaded. I even (on
windows-NT-system) could not load for example the php_dbg.dll,
php_pdf.dll extensions with PHP 4.1.1. May be someone can test this for
other extensions to find out if this is a general bug on
windows-systems.
Can someone help? Thanks
Klaus Habeck
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/12975
--
Edit this bug report at http://bugs.php.net/?id=12975&edit=1