#23367 [Fbk->Bgs]: Problems with loading every extension in the extensions dir

From: Date: Mon, 28 Apr 2003 14:06:07 +0000
Subject: #23367 [Fbk->Bgs]: Problems with loading every extension in the extensions dir
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-38561@lists.php.net to get a copy of this message
ID: 23367 Updated by: edink@php.net Reported By: Sebastian dot Hippler at t-online dot de -Status: Feedback +Status: Bogus Bug Type: Dynamic loading Operating System: Windows XP Pro SP1 PHP Version: 4.3.1 New Comment: You probably missed the bit in the manual (http://www.php.net/manual/en/ref.mcrypt.php) about downloading binary version of mcrypt library from http://ftp.proventum.net/pub/php/win32/misc/mcrypt/ Previous Comments: ------------------------------------------------------------------------ [2003-04-28 08:24:53] Kylotan at hotmail dot com ; Directory in which the loadable extensions (modules) reside. extension_dir = C:/PHP/extensions extension=php_mcrypt.dll (all other extensions are commented out) I explicitly set the permissions for 'everyone' to 'full control' on the dlls. Still no luck. ------------------------------------------------------------------------ [2003-04-28 07:40:57] derick@php.net How does the line in php.ini look like, and are you sure all .dlls have permissions to being executed/read by the Webserver User? (No idea how exactly this works in Windows) ------------------------------------------------------------------------ [2003-04-28 07:15:57] kylotan at hotmail dot com I've made sure all the dlls were installed in the prescribed places (in my case, php_mcrypt.dll in c:\php\extensions, and libmcrypt.dll in winnt/system32), updated php.ini to point at the correct extensions directory, and I get this message: PHP Warning: Unable to load dynamic library 'c:/php/extensions/php_mcrypt.dll' Yet that file is confirmed as existing. Even if I have made some error elsewhere in the setup, that warning message is either wrong or insufficient. ------------------------------------------------------------------------ [2003-04-26 18:36:59] derick@php.net You probably didn't copy the .dll's from the dll folder to somewhere in your path. It works fine for me, not a bug -> bogus. Derick ------------------------------------------------------------------------ [2003-04-26 18:20:19] Sebastian dot Hippler at t-online dot de HTTP Server = IIS 5.1 over ISAPI the Problem is that every try to load any extension of the extensions dir returns a messagebox what says "Unknown(); Unable to load the dynamical library "C:\PHP\extensions\php_pdf.dll" - the module wasn't found but the path is correct and everything is right (even case sensitivity) ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=23367&edit=1

« previous php.bugs (#38561) next »