#23429 [NEW]: pfsockopen open a persistent connection only with "localhost"

From: Date: Wed, 30 Apr 2003 14:28:34 +0000
Subject: #23429 [NEW]: pfsockopen open a persistent connection only with "localhost"
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-38833@lists.php.net to get a copy of this message
From: m dot antonini at inwind dot it Operating system: OSF1 V5.1 732 alpha PHP version: 4.3.2RC2 PHP Bug Type: Sockets related Bug description: pfsockopen open a persistent connection only with "localhost" Hi! When i try to open a socket connection below: $fd = pfsockopen("semarmx0034",1705); where semarmx0034 is the unix machine with apache web server ( 1.3.27 ) installed, this is the error message: Warning: pfsockopen(): php_network_getaddresses: getaddrinfo failed: Name does not resolv to supplied parameters; neither nodename nor servname were passed. in /dwt/LensTools/apache_1.3.24/htdocs/prova.php on line 2 Warning: pfsockopen(): unable to connect to semarmx0034:1705 in /dwt/LensTools/apache_1.3.24/htdocs/prova.php on line 2 if I try this $fd = pfsockopen("localhost",1705); $fd is a valid Resource id and persistent connection works well. if I try this $fd = pfsockopen("134.32.141.42",1705); this is the output message: Warning: pfsockopen(): php_network_getaddresses: getaddrinfo failed: Name does not resolv to supplied parameters; neither nodename nor servname were passed. in /dwt/LensTools/apache_1.3.24/htdocs/prova.php on line 2 Warning: pfsockopen(): unable to connect to 134.32.141.42:1705 in /dwt/LensTools/apache_1.3.24/htdocs/prova.php on line 2 why this function works only with "localhost" parameter in php 4.3.2RC2? I tested this function on my old php version ( 4.0.6 ) compiled on the same machine and works well with IP address Is it a unix configuration problem? Regards -- Edit bug report at http://bugs.php.net/?id=23429&edit=1 -- Try a CVS snapshot: http://bugs.php.net/fix.php?id=23429&r=trysnapshot Fixed in CVS: http://bugs.php.net/fix.php?id=23429&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=23429&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=23429&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=23429&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=23429&r=support Expected behavior: http://bugs.php.net/fix.php?id=23429&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=23429&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=23429&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=23429&r=globals PHP 3 support discontinued: http://bugs.php.net/fix.php?id=23429&r=php3 Daylight Savings: http://bugs.php.net/fix.php?id=23429&r=dst IIS Stability: http://bugs.php.net/fix.php?id=23429&r=isapi Install GNU Sed: http://bugs.php.net/fix.php?id=23429&r=gnused

« previous php.bugs (#38833) next »