Bug #11058 Updated: php_network_getaddresses: getaddrinfo failed
| From: | wez@php.net | Date: | Wed, 03 Apr 2002 16:34:10 +0000 |
| Subject: | Bug #11058 Updated: php_network_getaddresses: getaddrinfo failed | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-3934@lists.php.net to get a copy of this message | ||
ID: 11058
Updated by: wez@php.net
Reported By: pat@mail.rit.edu
Status: Bogus
Bug Type: Network related
Operating System: OpenBSD 2.6
PHP Version: 4.0.6
New Comment:
In your OS config that is.
Previous Comments:
------------------------------------------------------------------------
[2002-04-03 11:32:50] wez@php.net
If you have IPV6 support enabled, try turning it off,
or vice-versa.
------------------------------------------------------------------------
[2002-04-03 11:19:52] g.almasi@gigcity.com
I'm running SuSE 7.3 and I'm having this exact problem too. Has anyone
found a solution? I see the above comment about the problem being in
the system configuration and I'm wondering if someone could elaborate
on that. Thanks.
------------------------------------------------------------------------
[2002-02-07 03:31:35] navajo@slip.net
Im currently running into the same issue with the base
install of SUSE 7.3, fopen(), fsockopen(), and file() also
to not work with URL's or an ip address.
------------------------------------------------------------------------
[2001-12-07 09:12:30] sterling@php.net
its a problem with your operating system setup, not PHP.
------------------------------------------------------------------------
[2001-08-09 15:02:48] pat@mail.rit.edu
Still not resolved.
I commented out the line:
#define HAVE_GETADDRINFO 1
from my main/php_config.h file, did a make, then a make install.
Recompiled Apache, stopped and started the server, and still have the
same errors.
I also tried changing the value to 0, and did the same to #define
LIBRESOLV 1 to see if that was the problem (for some reason there are 2
identical lines with LIBRESOLV in my php_config.h file). Nothing.
Any ideas? This was working perfectly before upgrading to PHP4, and I
haven't touched the box except to upgrade Apache and install OpenSSL.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/11058
--
Edit this bug report at http://bugs.php.net/?id=11058&edit=1