#14409 [Fbk->NoF]: request for nonexistent file does not return 404 error

From: Date: Sat, 24 May 2003 06:20:17 +0000
Subject: #14409 [Fbk->NoF]: request for nonexistent file does not return 404 error
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-40333@lists.php.net to get a copy of this message
ID: 14409 Updated by: sniper@php.net Reported By: support at teamITS dot com -Status: Feedback +Status: No Feedback Bug Type: CGI related Operating System: IRIX64 www102 6.5 07091542 IP27 PHP Version: 4.3.1 New Comment: No feedback was provided. The bug is being suspended because we assume that you are no longer experiencing the problem. If this is not the case and you are able to provide the information that was requested earlier, please do so and change the status of the bug back to "Open". Thank you. Previous Comments: ------------------------------------------------------------------------ [2003-05-18 22:01:36] shane@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-STABLE-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-STABLE-latest.zip Tested with 4.3.2 on windows, 404's are returned fine. Please try the latest RC of 4.3.2. ------------------------------------------------------------------------ [2003-05-18 03:26:59] romio at netvision dot net dot il anything new with this bug ? ------------------------------------------------------------------------ [2003-05-08 04:48:35] romio at netvision dot net dot il yes this what I get on linux too. moreover you don't need to try accessing the file through the web you can execute something like that: php blah.php and this is what I got from php: Content-type: text/html X-Powered-By: PHP/4.3.1 PHP Fatal error: Unknown(): Unable to open blex.php in Unknown on line 0 php -v : PHP 4.3.1 (cgi), Copyright (c) 1997-2002 The PHP Group Zend Engine v1.3.0, Copyright (c) 1998-2002 Zend Technologies ------------------------------------------------------------------------ [2003-05-08 00:32:15] support at teamITS dot com Re-opening bug report. I do not see the Internal Server error, however the nonexistent PHP page (http://www.teamITS.com/blah.php) now returns: "Fatal error: Unknown(): Unable to open in Unknown on line 0" When installed as an Apache module (Windows, Apache 1.3.27) it returns the correct 404 error. ------------------------------------------------------------------------ [2003-05-07 17:45:33] romio at netvision dot net dot il I applyied the 4.3.0 "patch" basicaly replacing the old cgi_main.c with the downloaded one, compiled and installed. But it seems that the problem still exists. When ever calling to an unexisting file it still gives a 500 error. I have apache 1.3.27 and php 4.3.1 I configured php as follow : ./configure --enable-force-cgi-redirect --enable-safe-mode --with-openssl --with-zlib --with-gdbm --with-mysql --enable-memory-limit --with-gd --with-jpeg-dir=/usr/lib --with-zlib-dir=/usr/lib --with-png-dir=/usr/lib ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/14409 -- Edit this bug report at http://bugs.php.net/?id=14409&edit=1

« previous php.bugs (#40333) next »