#23975 [Opn->Asn]: dba_open locking error with db3

From: Date: Thu, 05 Jun 2003 06:28:34 +0000
Subject: #23975 [Opn->Asn]: dba_open locking error with db3
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-41233@lists.php.net to get a copy of this message
 ID:               23975
 Updated by:       sniper@php.net
 Reported By:      rhalstenbach at t-online dot de
-Status:           Open
+Status:           Assigned
 Bug Type:         DBM/DBA related
 Operating System: Windows
 PHP Version:      4.3.2
-Assigned To:      
+Assigned To:      helly
 New Comment:

Marcus, take a look?



Previous Comments:
------------------------------------------------------------------------

[2003-06-03 03:43:56] rhalstenbach at t-online dot de

The new locking feature (introduced with 4.3.0) does not work correctly
in default mode "d". Very annoying because it is the default mode ...

Example:

<?php
$d1 = dba_open("c:/www/htdocs/dbfile", "c", "db3); // Old syntax,
specifying no locking mode means mode "d", i.e. same as "cd"

if ($d1 === FALSE) die("Could not open dbfile");
?>

Same problem for mode "w".

It works correctly for locking mode "l" and for suppressing locking via
"-". Obviously the dba_open() function tries to create a lock file with
exactly the same name as the database file - what fails of course.

Tested on WindowsXP with db3, but i think it will fail for every
db-driver (except gdbm) on every OS.

------------------------------------------------------------------------


-- 
Edit this bug report at http://bugs.php.net/?id=23975&edit=1



Thread (11 messages)

« previous php.bugs (#41233) next »