#22937 [Csd->Opn]: Valid http:// URL does not open with fopen()

From: Date: Sat, 07 Jun 2003 17:06:48 +0000
Subject: #22937 [Csd->Opn]: Valid http:// URL does not open with fopen()
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-41436@lists.php.net to get a copy of this message
ID: 22937 User updated by: freddie at bingham dot net Reported By: freddie at bingham dot net -Status: Closed +Status: Open Bug Type: Sockets related Operating System: Redhat 7.3 -PHP Version: 4.3.1 +PHP Version: 4.3.2 New Comment: This is still happening in the 4.3.2 release This is the result of the above script: Warning: fopen(http://pub133.ezboard.com/bonesixthwarriors): failed to open stream: HTTP request failed! k› in test.php on line 3 Previous Comments: ------------------------------------------------------------------------ [2003-04-07 12:16:53] psvanvicat at yahoodot dot com I have a similar problem, but my virtual host has upgraded to 4.3.1 and I can't convince them to go back to a stable snapshot...anything I can do in my scripts to fix this? Any updates they can do? ------------------------------------------------------------------------ [2003-03-27 19:01:40] sniper@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-STABLE-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-STABLE-latest.zip Works fine here. (using latest stable CVS) ------------------------------------------------------------------------ [2003-03-27 18:41:30] freddie at bingham dot net Consider the following script: <?php $p = fopen('http://pub133.ezboard.com/bonesixthwarriors', 'rb'); $p2 = fopen('http://www.microsoft.com', 'rb'); ?> Both sites are opened when using php 4.2.3 (and earier version) whereas 4.3.1 throws the following warning: Warning: fopen(http://pub133.ezboard.com/bonesixthwarriors) [function.fopen]: failed to create stream: HTTP request failed! in /home/juan/public_html/forums/foo.php on line 3 Considering that the second fopen() generates no warnings, fopen is working in some cases in regards to urls. Of course, Apache has been restarted numerous times with no effect. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=22937&edit=1

« previous php.bugs (#41436) next »