#21914 [Opn->Bgs]: imap_open() fails with iMail POP3 server

From: Date: Wed, 11 Jun 2003 21:38:14 +0000
Subject: #21914 [Opn->Bgs]: imap_open() fails with iMail POP3 server
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-41710@lists.php.net to get a copy of this message
ID: 21914 Updated by: derick@php.net Reported By: jaime at iguana-farm dot com -Status: Open +Status: Bogus Bug Type: IMAP related Operating System: RedHat 7.2 PHP Version: 4.2.3 New Comment: Not a bug in PHP then -> bogus Previous Comments: ------------------------------------------------------------------------ [2003-06-11 16:14:32] jaime at iguana-farm dot com The CRAM-MD5 problem is a compatiblity problem beween c-client (all versions) and IMail. c-client folks claim that IMail is "non-compliant" while ipSwitch has no interest in correctting the problem. My workaround was to patch up the c-client pop3.c to check if is connection to an iMail server and set auths=0 in the function pop3_auth(). Jaime ------------------------------------------------------------------------ [2003-06-11 16:03:26] davidkoopman at yahoo dot com I have the same problem... $type = "pop"; $aServer = "mail.mycaboodle.com"; $spec = "{".$aServer.":".$aPort."/$type/notls"."}"."INBOX"; $mbox = @imap_open($spec, $aAccount['user_name'], $aAccount['password']); print_r(imap_errors()); results in: rray ( [0] => Retrying CRAM-MD5 authentication after [1] => Retrying CRAM-MD5 authentication after Invalid userid/password [2] => Retrying CRAM-MD5 authentication after illegal command [3] => Retrying CRAM-MD5 authentication after authentication exchange failed [4] => Can not authenticate to POP3 server: authentication exchange failed ) I am using imap-2002c1 for c-client under RH7.2. I am struggling with this because I can log in via command line. The mail server I am trying to connect to: mail.mycaboodle.com is running Imail 8.00, which is the only mail server I have seen in my hunting for a solution that this error occurs on. ------------------------------------------------------------------------ [2003-02-07 23:53:27] sniper@php.net No feedback was provided. The bug is being suspended because we assume that you are no longer experiencing the problem. If this is not the case and you are able to provide the information that was requested earlier, please do so and change the status of the bug back to "Open". Thank you. ------------------------------------------------------------------------ [2003-01-27 23:03:11] sniper@php.net Yes, this is most likely a c-client problem. But do try this call: imap_open("{mail.imailserver.com:110/pop3/notls}INBOX", .. (notice the 'notls' there..) And what versions of c-client did you use to build 4.0.6 and 4.2.3? And what were the configure lines used? It also depends a lot on how the c-client was build and with what options.. ------------------------------------------------------------------------ [2003-01-27 22:20:15] jaime at iguana-farm dot com I am to open a connection to an ipSwitch iMail ver 6.06 POP3 server using imap_open(). I have tried this under RedHat 7.2 and FreeBSD with PHP versions 4.2.3, 4.1.2 with the same results. Under FreeBSD ver 4.0.6 it works. [jaime@lizard test]$ php -q test.php <br /> <b>Warning</b>: Couldn't open stream {mail.seismicom2.com:110/pop3}INBOX in <b>.../test/test.php</b> on line <b>3</b><br /> Array ( [0] => Retrying CRAM-MD5 authentication after [1] => Retrying CRAM-MD5 authentication after Invalid userid/password [2] => Retrying CRAM-MD5 authentication after illegal command [3] => Retrying CRAM-MD5 authentication after authentication exchange failed [4] => Can not authenticate to POP3 server: authentication exchange failed ) [jaime@lizard test]$ cat test.php <?php $mbox = imap_open("{mail.imailserver.com:110/pop3}INBOX", "user", "passwd"); print_r(imap_errors()); ?> Is this a c-client problem? Thanks, Jaime ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=21914&edit=1

« previous php.bugs (#41710) next »