#24131 [Opn->Fbk]: session_start() warns about failed read
ID: 24131
Updated by: sniper@php.net
Reported By: meat at reed dot edu
-Status: Open
+Status: Feedback
Bug Type: Session related
Operating System: Linux 2.2.16-22 SMP
PHP Version: 4.3.2
New Comment:
Can you reproduce this within some other machine?
And are you sure it's not just some bug in that kernel?
(latest is 2.2.25 already.. :)
Previous Comments:
------------------------------------------------------------------------
[2003-06-11 17:41:59] meat at reed dot edu
This occurs both when session.save_path is the default
(/tmp) and when I set it to something else. The
session files are created successfully. Like I said in
the original submissions, the sessions appear to work
just fine, and the warning only happens when starting a
fresh session. It's totally possible that something is
broken on the system, but that would seem to be at odds
with the apparent functionality despite the warning.
------------------------------------------------------------------------
[2003-06-11 17:33:46] sniper@php.net
What is the session.save_path set to? And on what kind
of partition does that exist? (never seen this before, might be
something broken in your system..)
------------------------------------------------------------------------
[2003-06-11 13:17:49] meat at reed dot edu
This problem first occurred for me on PHP 4.3.2, and
installing the CVS snapshot for 6-10-2003 did not help.
When calling session_start() for the first time, in a
script as simple as this one:
<?php
session_start();
?>
This warning appears in the browser:
Warning: session_start(): read failed: Value too large
for defined data type (75) in /usr/local/httpd/webapp/
html/tools/lib/std.php on line 19
Line 19 in the above script is simply
"session_start()". If I preface the call with an @ to
turn off warnings/errors, then the script works as
intended. If I remove the @ while the session is
active, the error is not given, but as soon as I log
out (i.e. call session_destroy()), it comes back.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=24131&edit=1
Thread (8 messages)