#24186 [NEW]: Error Loading php as Apache module
| From: | jchong at uneven dot net | Date: | Sat, 14 Jun 2003 22:43:02 +0000 |
| Subject: | #24186 [NEW]: Error Loading php as Apache module | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-41917@lists.php.net to get a copy of this message | ||
From: jchong at uneven dot net
Operating system: Red Hat Linux 8.0 kernel 2.4.18
PHP version: 4.3.2
PHP Bug Type: Oracle related
Bug description: Error Loading php as Apache module
Description:
------------
I compile php 4.3.2 and configure with this:
./configure --with-config-file-path=/etc \
--with-apxs=/usr/local/apache/sbin/apxs \
--with-mysql=/usr --with-oracle=/var/oracle \
--with-oci8=/var/oracle \
--with-openssl=/usr \
--enable-libgcc \
--enable-ftp \
--enable-track-vars --enable-sysvsem --enable-sysvshm --enable-sockets \
--enable-pcntl --with-system-regex --enable-sigchild \
--with-zlib=/usr --with-mhash --with-mcrypt --with-mm=/usr
When installing and starting Apache I get:
Cannot load /usr/local/apache/libexec/libphp4.so into server:
/var/oracle/lib/libclntsh.so.9.0: undefined symbol: __cmpdi2
/usr/local/apache/sbin/apachectl start: httpd could not be started
--
Edit bug report at http://bugs.php.net/?id=24186&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=24186&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=24186&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=24186&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=24186&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=24186&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=24186&r=support
Expected behavior: http://bugs.php.net/fix.php?id=24186&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=24186&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=24186&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=24186&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=24186&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=24186&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=24186&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=24186&r=gnused