#14118 [Com]: Upload file more than 1 Mb doesn´t work
| From: | s_chhatre at yahoo dot com | Date: | Fri, 20 Jun 2003 11:12:18 +0000 |
| Subject: | #14118 [Com]: Upload file more than 1 Mb doesn´t work | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-42271@lists.php.net to get a copy of this message | ||
ID: 14118
Comment by: s_chhatre at yahoo dot com
Reported By: mlara at gcintl dot com
Status: Closed
Bug Type: Unknown/Other Function
Operating System: linux redhat 7.1
PHP Version: 4.0.4pl1
New Comment:
Yess...
changing the setting request_body_max_size to whatever size required
works fine and upload the file of whatever size required.
-Shrirang S. Chhatre.
Previous Comments:
------------------------------------------------------------------------
[2003-03-11 13:21:26] jgomes at ulbra-to dot br
Hi all,
I had the same problem using multiple platforms (PHP, ASP, .NET); so I
discovered that the problem is the Squid (Proxy) configuration. It has
a tag (request_body_max_size) that defines the maximum size of a HTTP
request body (the data area). So if you try to upload a file whose size
overlaps the limit, you'll get an error generated by Squid: "The page
cannot be found" or "The page coudn't be processed" and so on.
Thanks.
God bless!
[AJ(ack)]
------------------------------------------------------------------------
[2002-10-01 11:08:05] jbyu at csie dot nctu dot edu dot tw
I have same problem about upload large file.
My platform: Win2k + Apache 2.0.42 + PHP 4.1.2
The php.ini is also correct.
So what do i miss? httpd.conf?
------------------------------------------------------------------------
[2001-11-21 14:14:19] mlara at gcintl dot com
Thanks
I resolved my problem, the reason was that the squid configuration
limit the request size, I changed this value and I can upload file more
higher than 2 Mb .
Thanks for all, I´m sorry
Mauricio
------------------------------------------------------------------------
[2001-11-21 12:42:44] sniper@php.net
Please try with PHP 4.1.0RC3:
http://download.php.net/~zeev/php-4.1.0RC3.tar.gz
------------------------------------------------------------------------
[2001-11-20 09:16:58] mlara at gcintl dot com
My php.ini has track_errors = On
but the script return the same error "The page cannot be
displayed". when I try to upload a file higher 2 Mb, I´ve changed all
in my script and my php.ini but doesn´t work, please can you help me
suggest me another solution.
My script printed the post variables, if the file is lower than 2 mb
the variables are printed, but if the file is higher 2 mb I get the
error "The page cannot be
displayed", and the variables aren´t printed.
Maybe my apache.conf file has a error.Please help me
Thanks
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/14118
--
Edit this bug report at http://bugs.php.net/?id=14118&edit=1