#24338 [Bgs]: APXS Failure
ID: 24338
User updated by: jtjones at crimsonknight dot com
Reported By: jtjones at crimsonknight dot com
Status: Bogus
Bug Type: Compile Failure
Operating System: Solaris 9
PHP Version: 4.3.2
New Comment:
/opt/csw/apache/bin/apxs does exist, maybe you should try searching
google or Sun.com. The /opt directory is the default directory for
optional software packages to be installed in the Solaris Operating
Environment.
Now can I please get an answer to my question.
Previous Comments:
------------------------------------------------------------------------
[2003-06-25 18:14:08] sniper@php.net
/opt/csw/apache/bin/apxs does not exist, how could it work.
Please don't submit bug reports so easily, try Google/mailing lists
first.
------------------------------------------------------------------------
[2003-06-25 14:14:57] jtjones at crimsonknight dot com
Description:
------------
Here is the lasted command that I have tried to use for configure:
"./configure --with-apxs=/opt/csw/apache/bin/apxs
--enable-memory-limit=yes --enable-magic-quotes=yes --enable-libgcc
--with-mysql=/usr/local/mysql --enable-fastcgi
--with-zlib=/usr/include/zlib.h --with-bz2=/usr/local/bin/bzip2
--enable-bcmath --with-gd"
When I run this configure fails with the error:
"Sorry, I was not able to successfully run APXS."
The possible causes that it lists are completely not a problem for me,
I have Perl installed, Apache is compiled with DSO support (in fact I
have several modules already loaded), and as you can see I specified
the path to APXS in the config command.
I first thought that this might be an issue with my Apache install so I
re-installed it to the location it is at now. This did not produce any
different results. I have ran this config and several variations of it
as a regular user, su'ed and as root thinking that it might be a
permissions issue, still I get the same result.
When I use this:
"--with-apxs=/opt/csw/apache/bin" I get the error that it cannot
execute /opt/csw/apache/bin.
Reproduce code:
---------------
loading cache ./config.cache
checking host system type... sparc-sun-solaris2.9
checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
*****
checking for working const... yes
checking flex version... 2.5.4 (ok)
checking for pthreads_cflags... -pthreads
checking for pthreads_lib...
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS...
Sorry, I was not able to successfully run APXS. Possible reasons:
Expected result:
----------------
Not sure, I expected it to say configure completed successfully. (???)
Never had it configure completely yet.
Actual result:
--------------
Sorry, I was not able to successfully run APXS. Possible reasons:
1. Perl is not installed;
2. Apache was not compiled with DSO support (--enable-module=so);
3. 'apxs' is not in your path. Try to use --with-apxs=/path/to/apxs
The output of /opt/csw/apache/bin/apxs follows
./configure: /opt/csw/apache/bin/apxs: not found
configure: error: Aborting
Perl is installed, Apache is compiled with DSO support, and I specified
the path in the configure command.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=24338&edit=1
Thread (6 messages)