#21237 [Com]: Unresolved text symbol "in6addr_any"
| From: | tomislav at mare dot zesoi dot fer dot hr | Date: | Thu, 26 Jun 2003 16:14:51 +0000 |
| Subject: | #21237 [Com]: Unresolved text symbol "in6addr_any" | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-42551@lists.php.net to get a copy of this message | ||
ID: 21237
Comment by: tomislav at mare dot zesoi dot fer dot hr
Reported By: rzepa at ic dot ac dot uk
Status: No Feedback
Bug Type: Compile Failure
Operating System: Irix 6.5.16
PHP Version: 4.3.0
New Comment:
IPv6 is only available in Irix 6.5.19 or higher, but in
main/php_config.h HAVE_IPV6 is defined. Removing HAVE_IPV6 solves the
problem.
Previous Comments:
------------------------------------------------------------------------
[2003-03-09 18:46:52] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
------------------------------------------------------------------------
[2003-02-25 04:30:20] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
And if you get the same failure, check main/php_config.h
for HAVE_IPV6
------------------------------------------------------------------------
[2002-12-28 03:49:32] rzepa at ic dot ac dot uk
Previous difficulties in compiling at gcc 3.0.4 were
addressed by updating to gcc 3.1.1. The previous compile
error no longer occurs, but instead at link point, the
error
ld32: ERROR 33: Unresolved text symbol "in6addr_any" -- 1st
referenced by main/network.lo.
Use linker option -v to see when and which objects,
archives and dsos are loaded.
ld32: INFO 152: Output file removed because of error.
is obtained
./configure --with-mysql --with-apxs2=/var/www/apache2/
bin/apxs
against apache 2.0.40
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=21237&edit=1