ID: 23492
User updated by: dziugas dot baltrunas at m-1 dot lt
Reported By: dziugas dot baltrunas at m-1 dot lt
Status: Bogus
Bug Type: MySQL related
-Operating System: FreeBSD 4.8-RELEASE
+Operating System: FreeBSD 5.0-RELEASE
PHP Version: 4.3.1
New Comment:
I would like to announce that this issue has been solved recompiling
MySQL (4.0.13) together with LinuxThreads. Futhermore, this alteration
has raised another problem - wait_timeout parameter is weakless (tried
setting both in configuration file and manually using SET GLOBAL
wait_timeout).
Previous Comments:
------------------------------------------------------------------------
[2003-06-26 04:33:39] nefer at ib dot ru
Maybe. But i get it after upgrade from 4.3.2 to 4.3.3RC1... Alse when
i'm downgrade to 4.3.2 all works fine! MySQL stay untouched... Maybe
this is a sly bug in MySQL, but i like principe of Okkam blade.
------------------------------------------------------------------------
[2003-06-26 04:10:20] dziugas dot baltrunas at m-1 dot lt
Thanks for comment, nefer. I still think that this bug is *more*
related with MySQL, if you're intersted, here is my report's thread:
http://bugs.mysql.com/?id=398
This bug is becoming a bottleneck for me, so your help in debugging
mysql and php itself would be *very* appreciate.
------------------------------------------------------------------------
[2003-06-25 06:17:28] nefer at ib dot ru
I have the same situation. But i use 3.23.56 mysql and 'mysql
-p<blah-blah-blah>' command works perfectly. Also... I get this bug
after upgrading from 4.3.2 to 4.3.3RC1 version. So i think this is a
PHP bug.
------------------------------------------------------------------------
[2003-05-08 09:12:55] edink@php.net
Not a PHP bug then.
------------------------------------------------------------------------
[2003-05-08 09:11:40] dziugas dot baltrunas at m-1 dot lt
Sorry for this long story. I just realized that it's mysql bug itself:
<menulis@sala: menulis>$ while true; do mysql -hdb1 -upublic -psecret
-e'quit'; done
ERROR 1045: Access denied for user: 'public@10.10.12.254' (Using
password: NO)
ERROR 1045: Access denied for user: 'public@10.10.12.254' (Using
password: NO)
ERROR 1045: Access denied for user: 'public@10.10.12.254' (Using
password: NO)
ERROR 1045: Access denied for user: 'public@10.10.12.254' (Using
password: NO)
ERROR 1045: Access denied for user: 'public@10.10.12.254' (Using
password: NO)
ERROR 1045: Access denied for user: 'public@10.10.12.254' (Using
password: NO)
ERROR 1045: Access denied for user: 'public@10.10.12.254' (Using
password: NO)
ERROR 1045: Access denied for user: 'public@10.10.12.254' (Using
password: NO)
these errors appear occasionaly, each after 10-20 seconds.
thank you guys anyway, I will try to report it to MySQL.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/23492--
Edit this bug report at http://bugs.php.net/?id=23492&edit=1