Bug #16491 Updated: Fails to compile with apxs2

From: Date: Tue, 09 Apr 2002 08:25:13 +0000
Subject: Bug #16491 Updated: Fails to compile with apxs2
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-4400@lists.php.net to get a copy of this message
ID: 16491 Updated by: hjones@equiinet.com Reported By: hjones@equiinet.com Status: Bogus Bug Type: Apache2 related Operating System: Linux 2.4.2 PHP Version: 4.1.2 New Comment: Apache 2 was compiled with: ./configure --prefix=/opt/httpd --enable-expires --enable-headers --enable-davfs --enable-so --enable-dav --enable-info --enable-proxy --enable-proxy-connect --enable-proxy-ftp --enable-proxy-http --enable-ssl Previous Comments: ------------------------------------------------------------------------ [2002-04-08 16:49:28] sniper@php.net works fine here. I guess you have compiled apache2 wrong. Or there is some bug in it. Not PHP problem anyway. ------------------------------------------------------------------------ [2002-04-08 09:14:49] hjones@equiinet.com Also fails currently with 4.3.0-dev from CVS (at 14:15 BST) with the same error, just for info... ------------------------------------------------------------------------ [2002-04-08 09:02:33] sander@php.net Try RC3 from www.php.net/~derick when it's out (scheduled for the 12th of April). Reopen if it still fails. ------------------------------------------------------------------------ [2002-04-08 07:51:42] hjones@equiinet.com ./configure --with-apxs2=/opt/apache/bin/apxs --without-mysql produces: sapi_apache2.c:31:25: apr_strings.h: No such file or directory sapi_apache2.c:33:25: util_filter.h: No such file or directory This also happens with 4.2.0RC2 - unsure as to whether this is due to missing files with PHP or Apache 2.0.35 ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=16491&edit=1

« previous php.bugs (#4400) next »