#23833 [Fbk->NoF]: Cannot connect to Ingres II database (ingres_connect)

From: Date: Tue, 15 Jul 2003 07:25:24 +0000
Subject: #23833 [Fbk->NoF]: Cannot connect to Ingres II database (ingres_connect)
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-44017@lists.php.net to get a copy of this message
 ID:               23833
 Updated by:       sniper@php.net
 Reported By:      pm dot aubertel at free dot fr
-Status:           Feedback
+Status:           No Feedback
 Bug Type:         Ingres II related
 Operating System: Solaris 2.8
 PHP Version:      4.3.2RC4
 New Comment:

No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.




Previous Comments:
------------------------------------------------------------------------

[2003-07-09 15:54:10] sniper@php.net

Did you find any reasons why the sample program works and PHP not..?


------------------------------------------------------------------------

[2003-05-30 02:51:41] pm dot aubertel at free dot fr

The problem still remains when I call php directly:
  % php readdb.php
with readdb.php containing:
  <?php
  ingres_connect ("mydb") 
    or die ("Could not connect");
  print ("Connected successfully");
  ingres_close ();
  ?>
So it is not related to Apache.

Besides this, the asc sample program in the
Ingres distribution (<INGRES>/demo/api/asc) which uses
the same API as ii.c works perfectly...
I'm trying to understand why now.

------------------------------------------------------------------------

[2003-05-28 03:16:24] pm dot aubertel at free dot fr

I just cleaned, recompile and re-install php with
--disable-posix and do the same for apache but
the result is the same.

------------------------------------------------------------------------

[2003-05-27 17:45:28] sniper@php.net

Someone mentioned in the manual that adding --disable-posix made it
work for him..try adding that to your configure line.
(rm -f config.cache first!)


------------------------------------------------------------------------

[2003-05-27 10:16:44] pm dot aubertel at free dot fr

After  compiling and installing successfully php 4.3.2 RC over Apache
1.3.27
with Ingres II support, I cannot get the ingres_connect function to
work.

My php configure line is:
	./configure  --with-mysql
	--with-apache=/usr/local/apache_1.3.27 
	--with-gd 
	--with-zlib-dir 
	--with-ingres=/usr/local/ingres

The apache start script contains the lines:
II_SYSTEM=/usr/local
export II_SYSTEM

What I get in the apache error.log is:
[error] PHP Warning:  ingres_connect(): Ingres II:  Server or API error
: Unable to authenticate client's user ID. in
/export/home/www/dhs/php/readdb.php on line 28
[error] PHP Warning:  ingres_connect(): Ingres II:  SQLSTATE : 08004 in
/export/home/www/dhs/php/readdb.php on line 28
[error] PHP Warning:  ingres_connect(): Ingres II:  Unable to connect
to database (isis::basedhs15) in /export/home/www/dhs/php/readdb.php on
line 28

What I get in the Ingres errorlog.log:
isis    ::[33034      IIGCN, 00000001]: Tue May 27 15:54:40 2003
E_GC1008_INVALID_USER  Unable to authenticate client's user ID.

I have tried different user/passwd, some of them regisrred with
accessdb
but the result is always the same.



------------------------------------------------------------------------


-- 
Edit this bug report at http://bugs.php.net/?id=23833&edit=1



Thread (10 messages)

« previous php.bugs (#44017) next »