#21503 [Fbk->NoF]: Failed to write session data (Files).
ID: 21503
Updated by: sniper@php.net
Reported By: ccollins at totsp dot com
-Status: Feedback
+Status: No Feedback
Bug Type: Session related
Operating System: Red Hat Linux 7.3 - 2.4.18-18
PHP Version: 4.3.0
New Comment:
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
Previous Comments:
------------------------------------------------------------------------
[2003-07-12 21:41:23] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
[2003-01-08 10:34:09] ccollins at totsp dot com
space on /tmp is not an issue, there is 25GB avail on that partition.
------------------------------------------------------------------------
[2003-01-08 09:33:37] iliaa@php.net
Is it possible that you may running out of space in /tmp?
------------------------------------------------------------------------
[2003-01-07 20:40:14] ccollins at totsp dot com
I have very frequent errors in my logfiles concerning the session data.
"[07-Jan-2003 18:46:30] PHP Warning: Failed to write session data
(files). Please verify that the current setting of session.save_path is
correct (/tmp/php_sess) in Unknown on line 0"
Users are sometimes reporting a problem where sessions are not
maintained but this is apparently *usually* transparent to the users
and it is not often noticed.
The obvious things are in place, there IS a directory /tmp/php_sess and
it is owned by the webserver user. I am using PHP 4.3.0 in safe_mode,
as such:
session.save_handler = files
session.save_path = /tmp/php_sess
session.use_cookies = On
session.name = PHPSESSID
session.auto_start = 0
session.cookie_lifetime = 0
session.cookie_path = /
session.cookie_domain =
session.serialize_handler = php
session.gc_probability = On
session.gc_maxlifetime = 1440
session.entropy_length = 0
session.cache_limiter = nocache
session.cache_expire = 180
session.use_trans_sid = On
I have apparently had this problem for quite some time dating back to
4.2.x.
Please advise if there is anything I can try or do? I have read
through the other similar bug reports that do exist but they all refer
to version 4.2.3 and earlier and say the issue is solved in "later
version" or "snapshot".
Is this still a known issue in 4.3.0?
Thanks.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=21503&edit=1
Thread (7 messages)