ID: 5094
Comment by: clam at sluggy dot net
Reported By: infos at e-blokos dot com
Status: Closed
Bug Type: Dynamic loading related
Operating System: LinuxPPC
PHP Version: 4.0.0 Release
New Comment:
i have this same problem under php4.3.2 and apache 2.0.47
this is occuring on a gentoo-ppc
the error in my log:
Syntax error on line 3 of /etc/apache2/conf/modules.d/70_mod_php.conf:
Cannot load /etc/apache2/extramodules/libphp4.so into
server:/etc/apache2/extramodules/libphp4.so: R_PPC_REL24 relocation at
0x0ccfafb0 for symbol `_get_element_by_id' out of range
hope this helps
--will
Previous Comments:
------------------------------------------------------------------------
[2000-08-22 05:24:16] sniper@php.net
Previous feedback:
>> ok, thank you.>> i think that's the answer for my problem.>> I've forgotten the path ...
User feedback:
> Really, i don't know, and i'm very too overbooked to recompile PHP
and all
> other stuff like apache, etc...> So if you want a speed answer, i suggest you try to send to> linuxppc-user@lists.linuxppc.org your emails, apparently recently
there
> is a guy who 's have some prob with Php4.
----
Hmm, this must be general concensus (to be overbooked. =)
If some people have problems with php4 they should file a bug
report here if they suspect it is a bug. Or ask from
php-general@lists.php.net
I'm closing this one now. Please reopen if problem persists with newer
versions
and using --with-mysql=/path/to/mysql (when you have time to try it
out)
--Jani
------------------------------------------------------------------------
[2000-08-21 14:00:09] sniper@php.net
What is your configure line used for php4?
Try adding the path to the --with-mysql which points
to the prefix with which mysql was installed with.
--Jani
------------------------------------------------------------------------
[2000-08-20 03:57:44] sniper@php.net
Does this problem still persist with more recent version of php (from
CVS or http://snaps.php.net) ??
--Jani
------------------------------------------------------------------------
[2000-06-17 00:20:28] infos at e-blokos dot com
php 4 compiles fine with apache 1.3.12 mod_ssl 2.6.4, mod_perl 1.24 in
LINuXppc 2000
with apxs
when i restart apache it makes thsi error
R_PPC_REL24 relocation out of range
any suggestions
Thanks
Franck Chionna
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=5094&edit=1