From: mhawkins at ukeu dot com
Operating system: Solaris 8
PHP version: 4.3.2
PHP Bug Type: iPlanet related
Bug description: Failed opening phpinfo.php ... in Unknown on line 0
Description:
------------
PHP works fine for a period, then fails on all php pages with the below
error. This sometimes resolves itself after a few minutes, or sometimes is
resolved by restarting the httpd. This occurs regardless of whether the
php files are local or stored on nfs, so isn't a local network issue. This
occurs intermittantly (and at different times) across two identically
configured webservers.
No changes to the php.ini have been made. Both webservers are under a very
minimal load, and there are no cpu/memory/disk usage concerns. As far as I
can tell, the file permissions in /opt/sunone/es/bin and
/usr/local/php/lib/php are correct and unchanging, and the webservers have
read or read/write permissions to all the required files.
Please email me if more information is required.
Previous Bugs (both seem to be the same error as this):
#12995
#7163
Platform:
Solaris 8 (sparc)
SunONE Webserver 6.0 sp5 (AKA iplanet/netscape)
PHP 4.3.2
GCC 2.95.3
Error output (displayed in browser):
Warning: (null)(): Failed opening '/opt/sunone/es/docs/live/phpinfo.php'
for inclusion (include_path='.:/usr/local/php/lib/php') in Unknown on line
0
phpinfo.php:
<?php phpinfo(); ?>
configure:
./configure --prefix=/usr/local/php --with-mysql=/usr/local/mysql
--with-nsapi=/opt/sunone/es --enable-track-vars --enable-libgcc
obj.conf (extract):
<Object name="default">
...
Service fn="php4_execute" type="magnus-internal/x-httpd-php"
...
</Object>
<Object name="x-httpd-php" 2=">">
ObjectType fn="force-type" type="magnus-internal/x-httpd-php"
Service fn="php4_execute"
</Object>
magnus.conf (extract):
StackSize 131072
Init fn="load-modules"
funcs="php4_init,php4_close,php4_execute,php4_auth_trans"
shlib="/opt/sunone/es/bin/libphp4.so"
Init fn=php4_init errorString="Failed to initialize PHP!"
--
Edit bug report at http://bugs.php.net/?id=24882&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=24882&r=trysnapshot4
Try a CVS snapshot (php5): http://bugs.php.net/fix.php?id=24882&r=trysnapshot5
Fixed in CVS: http://bugs.php.net/fix.php?id=24882&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=24882&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=24882&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=24882&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=24882&r=support
Expected behavior: http://bugs.php.net/fix.php?id=24882&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=24882&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=24882&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=24882&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=24882&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=24882&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=24882&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=24882&r=gnused