#25135 [Opn->Fbk]: Strange redirection issue on missing page
| From: | iliaa@php.net | Date: | Mon, 18 Aug 2003 23:05:46 +0000 |
| Subject: | #25135 [Opn->Fbk]: Strange redirection issue on missing page | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-46140@lists.php.net to get a copy of this message | ||
ID: 25135
Updated by: iliaa@php.net
Reported By: kraj at illumen dot com
-Status: Open
+Status: Feedback
Bug Type: Apache related
Operating System: FreeBSD 4.8
PHP Version: 4.3.3RC4
New Comment:
Can you replicate the problem without Turck-MMCache?
Previous Comments:
------------------------------------------------------------------------
[2003-08-18 18:05:03] kraj at illumen dot com
http://www.icetips.com/sql/ runs http://www.icetips.com/sql.php
------------------------------------------------------------------------
[2003-08-18 18:02:49] kraj at illumen dot com
Forgot to mention - running Turck-MMCache
------------------------------------------------------------------------
[2003-08-18 18:01:05] kraj at illumen dot com
Description:
------------
OS - FreeBSD 4.8
PHP Version 4.3.3 RC2
Apache 1.3.28
We migrated a website which was totally static html to a new php site.
The search engines still point to pages on the old website.
The old website had a directory structure breaking up the site into
sections. The new website has a php script for each section.
As an example, the old website had a page access via the following
URL:
http://www.icetips.com/sql/mysqlpageloading.htm
If one tries to link to this page, instead of the document not found
page which is normally issued, the engine is running the script called
sql.php located on the document root, but none of the links work
because it believes that the base for the relative URL's is
http://www.icetips.com/sql/
THe proper behavior should be to display the ErrorDocument.
I am not sure if this is a problem caused by Apache or by PHP. If I
try to retrieve a page with a directory for which there is no php
script with the name (less the extension) which is the same as the
bogus directory then we are being redirected to the ErrorDocument
properly.
For example:
http://www.icetips.com/whatever/whenever.html
Could not test with either RC3 or RC4 because the ports collection does
not have those sources available at this time.
Reproduce code:
---------------
Access URL
http://www.icetips.com/sql/mysqlpageloading.htm
result in script
http://www.icetips.com/sql.php
being executed
Expected result:
----------------
Should display the ErrorDocument
Actual result:
--------------
Displays http://www.icetips.com/sql.php setting base
directory to
http://www.icetips.com/sql/
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=25135&edit=1