#25195 [Opn->Bgs]: Failed opening phpinfo.php ... in Unknown on line 0
| From: | iliaa@php.net | Date: | Wed, 27 Aug 2003 23:37:20 +0000 |
| Subject: | #25195 [Opn->Bgs]: Failed opening phpinfo.php ... in Unknown on line 0 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-46798@lists.php.net to get a copy of this message | ||
ID: 25195
Updated by: iliaa@php.net
Reported By: mhawkins at ukeu dot com
-Status: Open
+Status: Bogus
Bug Type: Mail related
Operating System: Solaris 8
PHP Version: 4.3.3
New Comment:
Sorry, but your problem does not imply a bug in PHP itself. For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system
is not the
appropriate forum for asking support questions.
Thank you for your interest in PHP.
On *nix systems when sending e-mail PHP uses popen() to open a pipe to
the sendmail binary. In your case that appears to fail, as far as my
man page can tell this can only happen if you are out of memory or
reached the maximum process limit causing fork()/pipe() to fail. As
such this is not a PHP issue.
Previous Comments:
------------------------------------------------------------------------
[2003-08-26 04:35:15] mhawkins at ukeu dot com
Installed the new snapshot, the bug is still occurring. The sendmail
path is echo'd the same as per the php.ini.
------------------------------------------------------------------------
[2003-08-21 18:59:52] sniper@php.net
If the problem persists with the snapshot, add this before the mail()
call:
echo ini_get('sendmail_path');
(just want to know if the path is still the same..)
------------------------------------------------------------------------
[2003-08-21 11:20:59] helly@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
[2003-08-21 11:15:10] mhawkins at ukeu dot com
Changing version level from 'irrelevant' to '4.3.3rc2'
------------------------------------------------------------------------
[2003-08-21 11:08:26] mhawkins at ukeu dot com
Description:
------------
Solaris 8 on Sparc
SunONE Webserver 6.0sp5 (AKA iplanet)
PHP 4.3.3RC2 (yes, I know, I should upgrade to RC4 first, but this is a
production system)
Sendmail - default as per Solaris 8.
Error:
PHP Warning: mail(): Could not execute mail delivery program in
/opt/sunone/es/docs/download.php on line 174
php.ini:
sendmail_path = "/usr/lib/sendmail -t -i"
config.status:
./configure --prefix=/usr/local/php --with-mysql=/usr/local/mysql
--with-nsapi=/opt/sunone/es --enable-track-vars --enable-libgcc
The code works perfectly for a few hours, sending mails as expected,
then the above error appears, and continues to fail until another
webserver restart is performed. Prior to the sendmail_path variable
being set, the error would log to /var/adm/messages, but since the
change it only logs to the webserver errorlog.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=25195&edit=1