#25339 [Fbk->Opn]: apxs:Error: Command failed with rc=65536

From: Date: Mon, 01 Sep 2003 12:16:38 +0000
Subject: #25339 [Fbk->Opn]: apxs:Error: Command failed with rc=65536
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-47001@lists.php.net to get a copy of this message
ID: 25339 User updated by: chris dot forker at clarologic dot com Reported By: chris dot forker at clarologic dot com -Status: Feedback +Status: Open Bug Type: Apache2 related Operating System: Mandrake Linux 9.1 PHP Version: 4.3.3 New Comment: Derick, Thanks for those suggestions. PHP is now installed. But I did get a warning: Warning! dlname not found in /opt/apache2/modules/libphp4.la. Is this a problem lurking, or is it OK to ignore ?? Many thanks for the help. Regards Chris Just for the record my configuration is now: ./configure \ --with-apxs2=/opt/apache2/bin/apxs \ --prefix=/opt/apache2/php \ --with-config-file-path=$prefix \ --with-zlib \ --with-bz2 \ --with-ttf \ --with-mysql \ --with-mysql-sock=/var/run/mysqld/mysqld.sock \ --disable-ipv6 \ --enable-roxen-zts \ --enable-track-vars \ --enable-force-cgi4-redirect \ --with-gettext Make Install output: [root@clukwebserver01 php-4.3.3]# make install Installing PHP CLI binary: /opt/apache2/php/bin/ Installing PHP CLI man page: /opt/apache2/php/man/man1/ Installing PHP SAPI module: apache2handler /opt/apache2/build/instdso.sh SH_LIBTOOL='/opt/apache2/build/libtool' libphp4.la /opt/apache2/modules /opt/apache2/build/libtool --mode=install cp libphp4.la /opt/apache2/modules/ cp .libs/libphp4.lai /opt/apache2/modules/libphp4.la cp .libs/libphp4.a /opt/apache2/modules/libphp4.a ranlib /opt/apache2/modules/libphp4.a chmod 644 /opt/apache2/modules/libphp4.a libtool: install: warning: remember to run `libtool --finish /tmp/PHP/php-4.3.3/libs' Warning! dlname not found in /opt/apache2/modules/libphp4.la. Assuming installing a .so rather than a libtool archive. chmod 755 /opt/apache2/modules/libphp4.so [activating module `php4' in /opt/apache2/conf/httpd.conf] Installing shared extensions: /opt/apache2/php/lib/php/extensions/no-debug-non-zts-20020429/ Installing PEAR environment: /opt/apache2/php/lib/php/ [PEAR] Archive_Tar - installed: 1.1 [PEAR] Console_Getopt - installed: 1.0 [PEAR] PEAR - installed: 1.2.1 Wrote PEAR system config file at: /opt/apache2/php/etc/pear.conf You may want to add: /opt/apache2/php/lib/php to your php.ini include_path [PEAR] DB - installed: 1.5.0RC1 [PEAR] HTTP - installed: 1.2.1 [PEAR] Mail - installed: 1.1.1 [PEAR] Net_SMTP - installed: 1.2.3 [PEAR] Net_Socket - installed: 1.0.1 [PEAR] XML_Parser - installed: 1.0.1 [PEAR] XML_RPC - installed: 1.0.4 Installing build environment: /opt/apache2/php/lib/php/build/ Installing header files: /opt/apache2/php/include/php/ Installing helper programs: /opt/apache2/php/bin/ program: phpize program: php-config program: phpextdist [root@clukwebserver01 php-4.3.3]# Previous Comments: ------------------------------------------------------------------------ [2003-09-01 06:52:02] derick@php.net Or this one btw: --disable-rpath \ Derick ------------------------------------------------------------------------ [2003-09-01 06:51:28] derick@php.net I think that this option in your original configure is the problem: --enable-static \ remove it and try again :) Derick ------------------------------------------------------------------------ [2003-09-01 06:50:13] chris dot forker at clarologic dot com Sniper, Thanks for your prompt reply. Tried what you suggested and as you can see below, no problems this time. What do you suggest I do to configure PHP with my original configure options ? Chris [root@clukwebserver01 php-4.3.3]# make install Installing PHP SAPI module: apache2handler /opt/apache2/build/instdso.sh SH_LIBTOOL='/opt/apache2/build/libtool' libphp4.la /opt/apache2/modules /opt/apache2/build/libtool --mode=install cp libphp4.la /opt/apache2/modules/ cp .libs/libphp4.so /opt/apache2/modules/libphp4.so cp .libs/libphp4.lai /opt/apache2/modules/libphp4.la libtool: install: warning: remember to run `libtool --finish /tmp/PHP/php-4.3.3/libs' chmod 755 /opt/apache2/modules/libphp4.so [activating module `php4' in /opt/apache2/conf/httpd.conf] Installing shared extensions: /usr/local/lib/php/extensions/no-debug-non-zts-20020429/ Installing build environment: /usr/local/lib/php/build/ Installing header files: /usr/local/include/php/ Installing helper programs: /usr/local/bin/ program: phpize program: php-config program: phpextdist [root@clukwebserver01 php-4.3.3]# ------------------------------------------------------------------------ [2003-09-01 06:34:30] sniper@php.net Try this: # rm config.cache #./configure --disable-all --disable-cli --with-apxs2=/opt/apache2/bin/apxs # make clean && make && make install ------------------------------------------------------------------------ [2003-09-01 05:19:33] chris dot forker at clarologic dot com Description: ------------ Hi, Trying to do a make install after compile of PHP 4.3.3 with Apache2 on Mandrake Linux 9.1. I cannot work out what is going wrong. I have tried replacing -lcrypt with -lc from suggestions I have seen posted with similar problems to mine but this results in a compile time error. Any help to resolve this would be appreciiated Regards Chris Apache2 Info: Apache/2.0.47 (Unix) DAV/2 SVN/0.25.0 mod_jk/1.2.3-dev PHP Make Install Info: [root@clukwebserver01 php-4.3.3]# make install Installing PHP CLI binary: /opt/apache2/php/bin/ Installing PHP CLI man page: /opt/apache2/php/man/man1/ Installing PHP SAPI module: apache2handler /opt/apache2/build/instdso.sh SH_LIBTOOL='/opt/apache2/build/libtool' libphp4.la /opt/apache2/modules /opt/apache2/build/libtool --mode=install cp libphp4.la /opt/apache2/modules/ cp .libs/libphp4.lai /opt/apache2/modules/libphp4.la cp .libs/libphp4.a /opt/apache2/modules/libphp4.a ranlib /opt/apache2/modules/libphp4.a chmod 644 /opt/apache2/modules/libphp4.a libtool: install: warning: remember to run `libtool --finish /tmp/PHP/php-4.3.3/libs' Warning! dlname not found in /opt/apache2/modules/libphp4.la. Assuming installing a .so rather than a libtool archive. chmod 755 /opt/apache2/modules/libphp4.so chmod: failed to get attributes of `/opt/apache2/modules/libphp4.so': No such file or directory apxs:Error: Command failed with rc=65536 . make: *** [install-sapi] Error 1 [root@clukwebserver01 php-4.3.3]# PHP Configuration Info: ./configure \ --with-apxs2=/opt/apache2/bin/apxs \ --prefix=/opt/apache2/php \ --with-config-file-path=$prefix \ --with-zlib \ --with-bz2 \ --with-ttf \ --with-mysql \ --with-mysql-sock=/var/run/mysqld/mysqld.sock \ --disable-rpath \ --disable-ipv6 \ --enable-static \ --enable-roxen-zts \ --enable-track-vars \ --enable-force-cgi4-redirect \ --with-gettext ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=25339&edit=1

« previous php.bugs (#47001) next »