#25388 [Opn->Bgs]: cannot load dynamic modules
| From: | sniper@php.net | Date: | Sat, 06 Sep 2003 13:14:21 +0000 |
| Subject: | #25388 [Opn->Bgs]: cannot load dynamic modules | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-47135@lists.php.net to get a copy of this message | ||
ID: 25388
Updated by: sniper@php.net
Reported By: jack at coldslaw dot co dot uk
-Status: Open
+Status: Bogus
Bug Type: Dynamic loading
Operating System: Redhat 9
PHP Version: 4.3.2
New Comment:
Not our problem. Report to RedHat.
Previous Comments:
------------------------------------------------------------------------
[2003-09-03 17:03:31] jack at coldslaw dot co dot uk
Description:
------------
the dynamic libraries are not loading after upgrading to version
4.3.2-7 [php, php-mysql,php-ldap,php-imap], apache 2.0.47-4
they ARE in the /usr/lib/php4/ path.
apache gives this error or startup
PHP Warning: Unknown(): Unable to load dynamic library
'/usr/lib/php4/imap.so' - /usr/lib/php4/imap.so: undefined symbol:
executor_globals in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library
'/usr/lib/php4/ldap.so' - /usr/lib/php4/ldap.so: undefined symbol:
OnUpdateInt in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library
'/usr/lib/php4/mysql.so' - /usr/lib/php4/mysql.so: undefined symbol:
OnUpdateInt in Unknown on line 0
configure line [from redhat rawhide rpm package]:
./configure' '--host=i386-redhat-linux' '--build=i386-redhat-linux'
'--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr'
'--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin'
'--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include'
'--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var'
'--sharedstatedir=/usr/com' '--mandir=/usr/share/man'
'--infodir=/usr/share/info' '--cache-file=../config.cache'
'--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d'
'--enable-force-cgi-redirect' '--disable-debug' '--enable-pic'
'--disable-rpath' '--enable-inline-optimization' '--with-bz2'
'--with-db4=/usr' '--with-curl' '--with-dom=/usr'
'--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr'
'--with-png-dir=/usr' '--with-gd' '--enable-gd-native-ttf'
'--with-ttf'
'--with-gdbm' '--with-gettext' '--with-ncurses' '--with-gmp'
'--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl'
'--with-png'
'--with-pspell' '--with-regex=system' '--with-xml'
'--with-expat-dir=/usr' '--with-pcre=/usr' '--with-zlib'
'--with-layout=GNU' '--enable-bcmath' '--enable-exif'
'--enable-ftp'
'--enable-magic-quotes' '--enable-safe-mode' '--enable-sockets'
'--enable-sysvsem' '--enable-sysvshm' '--enable-discard-path'
'--enable-track-vars' '--enable-trans-sid' '--enable-yp'
'--enable-wddx' '--without-oci8' '--with-pear=/usr/share/pear'
'--with-imap=shared' '--with-imap-ssl' '--with-kerberos'
'--with-ldap=shared' '--with-mysql=shared,/usr' '--with-pgsql=shared'
'--with-snmp=shared,/usr' '--with-snmp=shared'
'--enable-ucd-snmp-hack'
'--with-unixODBC=shared' '--enable-memory-limit' '--enable-bcmath'
'--enable-shmop' '--enable-versioning' '--enable-calendar'
'--enable-dbx' '--enable-dio' '--enable-mcal'
'--enable-mbstring'
'--enable-mbstr-enc-trans' '--enable-mbregex'
'--with-apxs2filter=/usr/sbin/apxs
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=25388&edit=1