#12358 [Com]: CGI Error-CGI application misbehaved

From: Date: Tue, 09 Sep 2003 15:21:10 +0000
Subject: #12358 [Com]: CGI Error-CGI application misbehaved
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-47324@lists.php.net to get a copy of this message
ID: 12358 Comment by: pachecodario at hotmail dot com Reported By: suresh_inbox at rediffmail dot com Status: Closed Bug Type: PWS related Operating System: windows 98 PHP Version: 4.0.6 New Comment: I think this problem is caused when the php is for Apache running with IIS on Windows 2000. It can be solved downloading the version for windows (Version 4.3.3, available in www.php.net). Installing that version it works, if you are running with IIS on Win XP it is necessary to set cgi.force_redirect=0 in your php.ini. I hope it can be the solution. Previous Comments: ------------------------------------------------------------------------ [2003-04-05 11:26:13] powerorb at gmx dot de Hi All, I had the same error all the time. In my case it were the Security-Settings inside the webroot. There need to be a entry like IUSR_XXXX (XXXX is the name of your computer). Give this user at least rights to read the directory. ------------------------------------------------------------------------ [2003-04-03 18:38:19] baje14 at eudoramail dot com i also have the same problem please please please help us! ------------------------------------------------------------------------ [2003-01-20 08:49:01] parryk at croner dot co dot uk it's a bit late now, but maybe someone else will come look for answers here... The CGI error can be solved by opening PWS, clicking on the Advanced button, and adding the folder where your scripts reside to the vitual directories tree (don't forget to enable the execute option by ticking the box). ------------------------------------------------------------------------ [2003-01-13 20:00:58] martinbudden at hotmail dot com I'm getting the same problem. It's not about setting cgi.force_redirect=0 in php.ini, that was for a different problem and that one is now fixed. So what is causing this error? Any help greatly appreciated! CGI Error The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are: ------------------------------------------------------------------------ [2002-06-25 03:55:17] renghen at servihoo dot com set cgi.force_redirect=0 in your php.ini ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/12358 -- Edit this bug report at http://bugs.php.net/?id=12358&edit=1

« previous php.bugs (#47324) next »